summary refs log tree commit diff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2023-08-12 23:05:50 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-08-13 12:41:56 +0800
commitcd5ebae25e76f9f1c91934b5c0f4a54e4e3086a9 (patch)
tree5de9f6f5c758f4c4bf47c586ad6645eea82e6597 /gnu/packages/kde-frameworks.scm
parent89a5785acd516e0637ca3ef670f2da62dc8cd08b (diff)
downloadguix-cd5ebae25e76f9f1c91934b5c0f4a54e4e3086a9.tar.gz
gnu: Add kimageannotator.
* gnu/packages/kde-frameworks.scm (kimageannotator): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 5bf09289b5..9778d9a1c6 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -50,6 +50,7 @@
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages docbook)
@@ -1842,6 +1843,43 @@ used by file indexers to retrieve the metadata.  This library can also be used
 by applications to write metadata.")
     (license (list license:lgpl2.0 license:lgpl2.1 license:lgpl3))))
 
+(define-public kimageannotator
+  (package
+    (name "kimageannotator")
+    (version "0.6.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ksnip/kImageAnnotator")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1gm85d1cnhf51ssj0gs2253fifl48r05d3q5s93jwk3jkq01inll"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:configure-flags #~'("-DBUILD_TESTS=ON")
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda _
+                   ;; 1 test requires a running X server, it calls
+                   ;; 'XCloseDisplay'.
+                   (system "Xvfb :1 -screen 0 640x480x24 &")
+                   (setenv "DISPLAY" ":1")
+                   (invoke "ctest" "--test-dir" "tests"))))))
+    (native-inputs
+     (list qttools-5 xorg-server-for-tests))
+    (inputs
+     (list googletest qtsvg-5 kcolorpicker))
+    (propagated-inputs
+     (list qtbase-5))
+    (home-page "https://github.com/ksnip/kImageAnnotator")
+    (synopsis "Image annotating library")
+    (description "This library provides tools to annotate images.")
+    (license license:lgpl3+)))
+
 (define-public kimageformats
   (package
     (name "kimageformats")