summary refs log tree commit diff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-23 01:57:26 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-03 17:38:10 +0800
commit25522d52f13fd1814b4b9abbb21b8e3d418f5d0e (patch)
tree355dff5328a9550c75434fa3be33f7972bcb4ccc /gnu/packages/kde-plasma.scm
parent80556494282f5ffddb937455ae535de33b3e66ba (diff)
downloadguix-25522d52f13fd1814b4b9abbb21b8e3d418f5d0e.tar.gz
gnu: plasma: Cleanup propagated-inputs.
* gnu/packages/kde-plasma.scm (plasma)[inputs]: Add kdeclarative, baloo,
breeze-icons, ktexteditor, kdesu,krunner, plasma-welcome, dolphin, konsole,
kglobalaccel.  Remove kwayland-integration, kwrited, layer-shell-qt.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm55
1 files changed, 37 insertions, 18 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 7ba316b5ff..4927e30705 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1449,52 +1449,71 @@ on top of Baloo.")
     (arguments
      (list #:builder #~(begin
                          (mkdir #$output))))
-    (propagated-inputs (list bluedevil
+    ;; TODO: cleanup, check what is no need
+    (propagated-inputs (list kdeclarative ;; require by sddm breeze theme
+
+                             baloo
+                             breeze-icons ; default mouse icon
                              breeze
                              breeze-gtk
-                             discover
                              drkonqi
-                             kactivitymanagerd
+                             kactivitymanagerd ; require this run dbus
                              kde-cli-tools
-                             ;; kde-gtk-config
                              kdecoration
                              kdeplasma-addons
                              kgamma
                              khotkeys
-                             kinfocenter
-                             kmenuedit
+                             ktexteditor
+
                              kscreen
-                             kscreenlocker
-                             ksshaskpass
+                             libkscreen
+
                              ksystemstats
                              kwallet-pam
-                             kwayland-integration
                              kwin
-                             kwrited
                              kinit
-                             layer-shell-qt
-                             libkscreen
+
                              libksysguard
                              milou
                              ;; oxygen
                              oxygen-sounds
+
+                             kdesu
+                             krunner
+                             kinfocenter
+                             kscreenlocker
+                             ksshaskpass
+                             discover
+                             kmenuedit
+                             plasma-welcome
                              plasma-browser-integration
                              plasma-desktop
                              plasma-disks
+                             polkit-kde-agent
+                             system-settings
+                             xdg-desktop-portal-kde
+                             ;; module cyclic referencing
+                             (module-ref
+                              (resolve-interface
+                               '(gnu packages kde-systemtools))
+                              'dolphin)
+                             (module-ref
+                              (resolve-interface
+                               '(gnu packages kde-systemtools))
+                              'konsole)
+                             ;; kde-gtk-config ;; TODO
+
                              plasma-firewall
                              plasma-integration
                              plasma-nm
                              plasma-pa
                              plasma-systemmonitor
                              ;; plasma-thunderbolt ;; waiting for bolt
+
+                             kglobalaccel
                              plasma-vault
                              plasma-workspace
-                             plasma-workspace-wallpapers
-                             polkit-kde-agent
-                             powerdevil
-                             sddm
-                             system-settings
-                             xdg-desktop-portal-kde))
+                             powerdevil))
     (synopsis "The KDE Plasma desktop environment")
     (home-page "https://kde.org/plasma-desktop/")
     (description