summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-28 23:08:42 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:08 +0100
commit263280fd64ef88522ac2cefdd3a2cbd5570c9f48 (patch)
tree6eeef1512436e56a800d31604ce0e60c880aab62 /gnu/packages/kde.scm
parent448df3cde19e648c8ac65472b10bc8011e5d4151 (diff)
downloadguix-263280fd64ef88522ac2cefdd3a2cbd5570c9f48.tar.gz
gnu: Add kio-extras.
* gnu/packages/kde.scm (kio-extras): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 9a855712f6..fe76366b65 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -68,6 +68,7 @@
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gimp)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gps)
   #:use-module (gnu packages graphics)
@@ -443,6 +444,50 @@ a module for implementing ODF Gantt charts, which are bar charts that
 illustrate project schedules.")
     (license license:gpl2+)))
 
+(define-public kio-extras
+  (package
+    (name "kio-extras")
+    (version "22.08.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/release-service/"
+                                  version "/src/" name "-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0gzna2ps2qd2js28c97kjpcbah7zz8n4s4932faggc2nz5z5wnyn"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (setenv "HOME" (getcwd))
+                              (setenv "TMPDIR" (getcwd))
+                              (invoke "ctest" "-E" "testkioarchive")))))))
+    (native-inputs (list extra-cmake-modules dbus kdoctools qttools-5))
+    (inputs (list karchive
+                  kconfig
+                  kconfigwidgets
+                  kcoreaddons
+                  kdbusaddons
+                  ki18n
+                  kdnssd
+                  kio
+                  solid
+                  kbookmarks
+                  kguiaddons
+                  ksyntaxhighlighting
+                  qtbase-5
+                  qtsvg-5))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Additional components to increase the functionality of KIO")
+    (description
+     "This package provides additional components to increase
+the functionality of the KDE resource and network access abstractions.")
+    (license license:lgpl2.0+)))
+
+
 (define-public kseexpr
   (package
     (name "kseexpr")