summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-20 01:45:38 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:21 +0100
commit9d95d8bd120072cb3b983da86baa645c5b2ecd89 (patch)
treee3ffd1382b73567a91b77b64bf69d9608ebfeef4 /gnu/packages/kde.scm
parent639b6ead0c96916ac47eefd03861c023a3026148 (diff)
downloadguix-9d95d8bd120072cb3b983da86baa645c5b2ecd89.tar.gz
gnu: Add kdiagram.
* gnu/packages/kde.scm (kdiagram): New variable.
* packages/patches/kdiagram-Fix-missing-link-libraries.patch: New file.
* gnu/local.mk: Add it.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 8a612bfe5b..c4576c8ba7 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -325,6 +325,37 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
 ;; kdevplatform was merged into kdevelop as of 5.2.x
 (define-deprecated kdevplatform kdevelop)
 
+(define-public kdiagram
+  (package
+    (name "kdiagram")
+    (version "2.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/kdiagram/" version
+                           "/kdiagram-" version ".tar.xz"))
+       (sha256
+        (base32 "1c6dbp9gssjrx59z8yxzq1ay56pnw7h28symjrv0gcvhxyjirrxx"))
+       (patches (search-patches
+                 "kdiagram-Fix-missing-link-libraries.patch"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)))
+    (home-page "https://cgit.kde.org/kdiagram.git/")
+    (synopsis "Libraries for creating business diagrams")
+    (description "This package provides libraries for integrating business
+diagrams in Qt-based applications.
+
+@code{KCharts} provides an implementation of the ODF Chart specification.  It
+supports stock charts, box charts, and whisker charts.  @code{KGantt} provides
+a module for implementing ODF Gantt charts, which are bar charts that
+illustrate project schedules.")
+    (license license:gpl2+)))
+
 (define-public krita
   (package
     (name "krita")