summary refs log tree commit diff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-08-20 19:30:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-08-24 12:32:34 +0200
commite3c13d044f8c7fdeef5079e16591dc4302f5c31b (patch)
tree68b0915264de8081d93e14667c0744907d5b6da9 /gnu/packages/kde.scm
parent2d6da7942a26af79f5051aeffc3a348c9ef0723f (diff)
downloadguix-e3c13d044f8c7fdeef5079e16591dc4302f5c31b.tar.gz
gnu: libksysguard: Enable more tests (not all working yet).
* gnu/packages/kde.scm (libksysguard)[arguments]
  <#:phases>'check-setup': Set QT_QPA_PLATFORM=offscreen.
  <#:phases>'check': Enable all tests except of the failing one.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index a65a61f96b..2e46a3c924 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -300,9 +300,14 @@ used in KDE development tools Kompare and KDevelop.")
              ;; KF5AuthConfig.cmake.in contains this already.
              (substitute* "processcore/CMakeLists.txt"
                (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
+         (add-before 'check 'check-setup
+           (lambda _
+             ;; make Qt render "offscreen", required for tests
+             (setenv "QT_QPA_PLATFORM" "offscreen")))
          (replace 'check
-           (lambda _         ;other tests require a display and therefore fail
-             (zero? (system* "ctest" "-R" "chronotest")))))))
+           (lambda _
+             ;; TODO: Fix this failing test-case
+             (zero? (system* "ctest" "-E" "processtest")))))))
     (home-page "https://www.kde.org/info/plasma-5.10.4.php")
     (synopsis "Network enabled task and system monitoring")
     (description "KSysGuard can obtain information on system load and