summary refs log tree commit diff
path: root/gnu/packages/libcanberra.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-13 12:14:08 -0500
committerMark H Weaver <mhw@netris.org>2015-01-13 12:14:08 -0500
commita813710a5fb0822e9d95088462d70f6522fe8457 (patch)
tree35299db4712eda92c809635716d530d085223e81 /gnu/packages/libcanberra.scm
parentd8cd15949092b7cd90ee1dcc4aefe87b3ba4a6fb (diff)
parent765f0ac8f9f67f775a667a4276faf85ddde6d7ea (diff)
downloadguix-a813710a5fb0822e9d95088462d70f6522fe8457.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/libcanberra.scm')
-rw-r--r--gnu/packages/libcanberra.scm31
1 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/libcanberra.scm b/gnu/packages/libcanberra.scm
index 859740aaee..0ffae1f674 100644
--- a/gnu/packages/libcanberra.scm
+++ b/gnu/packages/libcanberra.scm
@@ -19,6 +19,7 @@
 
 (define-module (gnu packages libcanberra)
   #:use-module ((guix licenses) #:select (lgpl2.1+))
+  #:use-module (gnu packages)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -46,7 +47,21 @@
             version ".tar.xz"))
       (sha256
        (base32
-        "0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))))
+        "0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))
+      ;; "sound-theme-freedesktop" is the default and fall-back sound theme for
+      ;; XDG desktops and should always be present.
+      ;; http://www.freedesktop.org/wiki/Specifications/sound-theme-spec/
+      ;; We make sure libcanberra will find it.
+      ;;
+      ;; We add the default sounds store directory to the code dealing with
+      ;; XDG_DATA_DIRS and not XDG_DATA_HOME. This is because XDG_DATA_HOME
+      ;; can only be a single directory and is inspected first.  XDG_DATA_DIRS
+      ;; can list an arbitrary number of directories and is only inspected
+      ;; later.  This is designed to allows the user to modify any theme at
+      ;; his pleasure.
+      (patch-flags '("-p0"))
+      (patches
+       (list (search-patch "libcanberra-sound-theme-freedesktop.patch")))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)
@@ -55,9 +70,21 @@
        ("libltdl" ,libltdl)
        ("libvorbis" ,libvorbis)
        ("pulseaudio" ,pulseaudio)
-       ("udev" ,eudev)))
+       ("udev" ,eudev)
+       ("sound-theme-freedesktop" ,sound-theme-freedesktop)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:phases
+       (alist-cons-before
+        'build 'patch-default-sounds-directory
+        (lambda* (#:key inputs #:allow-other-keys)
+          (substitute* "src/sound-theme-spec.c"
+            (("@SOUND_THEME_DIRECTORY@")
+             (string-append
+              (assoc-ref inputs "sound-theme-freedesktop")
+              "/share"))))
+        %standard-phases)))
     (home-page "http://0pointer.de/lennart/projects/libcanberra/")
     (synopsis
      "Implementation of the XDG Sound Theme and Name Specifications")