summary refs log tree commit diff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-17 23:29:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-17 23:32:35 +0100
commit7f6592c453b960eb3cbb25d1960f9c266a007a28 (patch)
tree890664f053a02adac97b9055f3294703371d6daa /gnu/packages/libusb.scm
parentb7dfc5a707bebc4b6fecd8a6e5bcca618b5acc12 (diff)
downloadguix-7f6592c453b960eb3cbb25d1960f9c266a007a28.tar.gz
gnu: hidapi: Update to 0.9.0.
This release was taken over by the libusb team.
See <https://github.com/signal11/hidapi/issues/373>.

* gnu/packages/libusb.scm (hidapi): Update to 0.9.0.
[source, home-page]: Switch to new upstream.
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index ae904fe5a9..629bcf5fe5 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -525,15 +525,15 @@ devices.")
 (define-public hidapi
   (package
     (name "hidapi")
-    (version "0.8.0-rc1")
+    (version "0.9.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/signal11/hidapi.git")
+             (url "https://github.com/libusb/hidapi.git")
              (commit (string-append "hidapi-" version))))
        (sha256
-        (base32 "13d5jkmh9nh4c2kjch8k8amslnxapa9vkqzrk1z6rqmw8qgvzbkj"))))
+        (base32 "1p4g8lgwj4rki6lbn5l6rvwj0xlbn1xfh4d255bg5pvgczmwmc4i"))))
     (build-system gnu-build-system)
     (inputs
      `(("libusb" ,libusb)
@@ -543,7 +543,7 @@ devices.")
        ("automake" ,automake)
        ("libtool" ,libtool)
        ("pkg-config" ,pkg-config)))
-    (home-page "http://www.signal11.us/oss/hidapi/")
+    (home-page "https://github.com/libusb/hidapi")
     (synopsis "HID API library")
     (description
      "HIDAPI is a library which allows an application to interface with USB and Bluetooth