summary refs log tree commit diff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-08 20:04:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-09 11:04:36 +0200
commit043b3dd45742c1ede1a6a97375af2e4b2d63691b (patch)
tree4e10ba074ddf1ab47e3bb8064863315ed2f93248 /gnu/packages/linphone.scm
parent850b3b116a8231ced1633d349f91a7da614ca101 (diff)
downloadguix-043b3dd45742c1ede1a6a97375af2e4b2d63691b.tar.gz
gnu: linphone-desktop: Update to 5.0.14.
* gnu/packages/linphone.scm (linphone-desktop): Update to 5.0.14.
[arguments]: Use G-expressions; add pre-install phase.
* gnu/packages/patches/linphone-desktop-without-sdk.patch: Update.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm78
1 files changed, 46 insertions, 32 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 3beb8c7ab8..4666216975 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -818,7 +818,7 @@ and video calls or instant messaging capabilities to an application.")
 (define-public linphone-desktop
   (package
     (name "linphone-desktop")
-    (version "4.2.5")
+    (version "5.0.14")
     (source
      (origin
        (method git-fetch)
@@ -827,41 +827,55 @@ and video calls or instant messaging capabilities to an application.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1gq4l9p21rbrcksa7fbkzn9fzbbynqmn6ni6lhnvzk359sb1xvbz"))
+        (base32 "0glrfsp087ni5hn6x6p4f6y63r4nyp061yyy0rfgddbxkzdqi2j1"))
        (patches (search-patches "linphone-desktop-without-sdk.patch"))))
     (build-system qt-build-system)
     (outputs '("out" "debug"))
     (arguments
-     `(#:tests? #f                      ; No test target
-       #:configure-flags (list "-DENABLE_UPDATE_CHECK=NO"
-                               "-DENABLE_DAEMON=YES"
-                               "-DENABLE_CONSOLE_UI=YES")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'pre-configure
-           (lambda _
-             (make-file-writable "linphone-app/linphoneqt_version.cmake")
-             (substitute* "linphone-app/linphoneqt_version.cmake"
-               (("\\$\\{GUIX-SET-VERSION\\}") ,version))))
-         (add-after 'install 'post-install
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (liblinphone (assoc-ref inputs "liblinphone"))
-                    (grammar-dest (string-append out "/share/belr/grammars")))
-               ;; Remove unnecessary Qt configuration file.
-               (delete-file (string-append out "/bin/qt.conf"))
-               ;; Not using the FHS exposes an issue where the client
-               ;; refers to its own directories, which lacks files
-               ;; installed by the dependencies.
-               (symlink (string-append liblinphone "/lib")
-                        (string-append out "/lib"))
-               (symlink (string-append liblinphone "/share/sounds")
-                        (string-append out "/share/sounds"))
-               (symlink (string-append liblinphone "/share/linphone/rootca.pem")
-                        (string-append out "/share/linphone/rootca.pem"))
-               (mkdir-p (dirname grammar-dest))
-               (symlink (string-append liblinphone "/share/belr/grammars")
-                        grammar-dest)))))))
+     (list
+      #:tests? #f                       ; No test target
+      #:configure-flags
+      #~(list (string-append "-DFULL_VERSION=" #$version)
+              (string-append "-DCMAKE_INSTALL_PREFIX=" #$output)
+              (string-append "-DCMAKE_INSTALL_BINDIR=" #$output "/bin")
+              (string-append "-DCMAKE_INSTALL_DATAROOTDIR=" #$output "/share")
+              (string-append "-DCMAKE_INSTALL_LIBDIR=" #$output "/lib")
+              "-DENABLE_UPDATE_CHECK=NO"
+              "-DENABLE_DAEMON=YES"
+              "-DENABLE_CONSOLE_UI=YES")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'pre-configure
+            (lambda _
+              (make-file-writable "linphone-app/linphoneqt_version.cmake")
+              (substitute* "linphone-app/linphoneqt_version.cmake"
+                (("\\$\\{GUIX-SET-VERSION\\}") #$version))))
+          (add-before 'install 'pre-install
+            (lambda _
+              (mkdir-p (string-append #$output "/share/linphone"))
+              (symlink (string-append #$(this-package-input "liblinphone")
+                                      "/share/sounds")
+                       (string-append #$output
+                                      "/share/sounds"))))
+          (add-after 'install 'post-install
+            (lambda _
+              (let* ((liblinphone #$(this-package-input "liblinphone"))
+                     (grammar-dest (string-append #$output "/share/belr/grammars")))
+                ;; Remove unnecessary Qt configuration file.
+                (delete-file (string-append #$output "/bin/qt.conf"))
+                ;; Not using the FHS exposes an issue where the client
+                ;; refers to its own directories, which lacks files
+                ;; installed by the dependencies.
+                (for-each
+                 (lambda (file)
+                   (symlink file
+                            (string-append #$output "/lib/" (basename file))))
+                 (find-files (string-append liblinphone "/lib")))
+                (symlink (string-append liblinphone "/share/linphone/rootca.pem")
+                         (string-append #$output "/share/linphone/rootca.pem"))
+                (mkdir-p (dirname grammar-dest))
+                (symlink (string-append liblinphone "/share/belr/grammars")
+                         grammar-dest)))))))
     (native-inputs
      (list pkg-config qttools-5))
     (inputs