summary refs log tree commit diff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-19 21:51:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-19 22:04:46 -0400
commit48acdefe2e39278bb53ab54995e4a2aca973e99c (patch)
treef455977fef4ba62f232f94877ab1f40106948faf /gnu/packages/linphone.scm
parent7abe35febe4234609e14e169b6fcc0cbaf4c7119 (diff)
downloadguix-48acdefe2e39278bb53ab54995e4a2aca973e99c.tar.gz
gnu: linphoneqt: Add the missing ring sound files.
* gnu/packages/linphone.scm (linphoneqt)[phases]: Add an
'extend-shared-resources phase.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 4f142312cc..b9d455ab3e 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -501,7 +501,17 @@ and video calls or instant messaging capabilities to an application.")
              (substitute* "src/app/AppController.cpp"
                (("LINPHONE_QT_GIT_VERSION")
                 (format #f "~s" ,version)))
-             #t)))))
+             #t))
+         (add-after 'install 'extend-shared-resources
+           ;; Not using the FHS exposes an issue where the client refers to
+           ;; its own "share" directory, which lacks sound files installed by
+           ;; liblinphone.
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((liblinphone (assoc-ref inputs "linphone"))
+                    (out (assoc-ref outputs "out")))
+               (symlink (string-append liblinphone "/share/sounds")
+                        (string-append out "/share/sounds"))
+               #t))))))
     (native-inputs
      `(("qttools" ,qttools)))
     (inputs