summary refs log tree commit diff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/linphone.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm57
1 files changed, 22 insertions, 35 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 1c60e767b0..285ecb58fd 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -122,7 +122,7 @@
                   (string-append out "/share/BCUnit/Examples")
                   (string-append doc "/share/BCUnit/Examples"))))))))
       (inputs
-       `(("ncurses" ,ncurses)))
+       (list ncurses))
       (synopsis "Belledonne Communications Unit Testing Framework")
       (description "BCUnit is a fork of the defunct project CUnit, with
 several fixes and patches applied.  It is a unit testing framework for
@@ -235,7 +235,7 @@ Communications software like belle-sip, mediastreamer2 and linphone.")
                 ;; name, so have it match.
                 (string-append tester "/share/belr_tester"))))))))
     (inputs
-     `(("bctoolbox" ,bctoolbox)))
+     (list bctoolbox))
     (synopsis "Belledonne Communications Language Recognition Library")
     (description "Belr is Belledonne Communications' language recognition
 library, written in C++11.  It parses text inputs formatted according to a
@@ -293,8 +293,7 @@ IETF.")
                                                      "/bin/belcard_tester")))
                  (invoke belcard_tester))))))))
     (inputs
-     `(("bctoolbox" ,bctoolbox)
-       ("belr" ,belr)))
+     (list bctoolbox belr))
     (synopsis "Belledonne Communications VCard Library")
     (description "Belcard is a C++ library to manipulate VCard standard
 format.")
@@ -445,7 +444,7 @@ such as conferencing.")
      `(("dot" ,graphviz)
        ("doxygen" ,doxygen)))
     (inputs
-     `(("bctoolbox" ,bctoolbox)))
+     (list bctoolbox))
     (synopsis "Belledonne Communications RTP Library")
     (description "oRTP is a C library implementing the RTP protocol.  It
 implements the RFC 3550 standard.")
@@ -552,9 +551,7 @@ including both ARM and x86.")
                                ;;"HTTP stack"
                                "Object"))))))))
     (inputs
-     `(("avahi" ,avahi)
-       ("bctoolbox" ,bctoolbox)
-       ("zlib" ,zlib)))
+     (list avahi bctoolbox zlib))
     (synopsis "Belledonne Communications SIP Library")
     (description "Belle-sip is a modern library implementing SIP transport,
 transaction and dialog layers.  It is written in C, with an object-oriented
@@ -721,9 +718,7 @@ including media capture, encoding and decoding, and rendering.")
      `(("dot" ,graphviz)
        ("doxygen" ,doxygen)))
     (inputs
-     `(("bctoolbox" ,bctoolbox)
-       ("belle-sip" ,belle-sip)
-       ("soci" ,soci)))
+     (list bctoolbox belle-sip soci))
     (synopsis "Belledonne Communications Encryption Library")
     (description "LIME is an encryption library for one-to-one and group
 instant messaging, allowing users to exchange messages privately and
@@ -851,21 +846,20 @@ and video calls or instant messaging capabilities to an application.")
                (symlink (string-append liblinphone "/share/belr/grammars")
                         grammar-dest)))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("qttools" ,qttools)))
+     (list pkg-config qttools))
     (inputs
-     `(("bctoolbox" ,bctoolbox)
-       ("belcard" ,belcard)
-       ("belr" ,belr)
-       ("liblinphone" ,liblinphone)
-       ("mediastreamer2" ,mediastreamer2)
-       ("ortp" ,ortp)
-       ("qtbase" ,qtbase-5)
-       ("qtdeclarative" ,qtdeclarative)
-       ("qtgraphicaleffects" ,qtgraphicaleffects)
-       ("qtquickcontrols" ,qtquickcontrols)
-       ("qtquickcontrols2" ,qtquickcontrols2)
-       ("qtsvg" ,qtsvg)))
+     (list bctoolbox
+           belcard
+           belr
+           liblinphone
+           mediastreamer2
+           ortp
+           qtbase-5
+           qtdeclarative
+           qtgraphicaleffects
+           qtquickcontrols
+           qtquickcontrols2
+           qtsvg))
     (synopsis "Desktop client for the Linphone SIP softphone")
     (description "Linphone is a SIP softphone for voice and video over IP calling
 (VoIP) and instant messaging.  Amongst its features are:
@@ -911,10 +905,7 @@ and video calls or instant messaging capabilities to an application.")
          #:configure-flags
          (list "-DENABLE_STATIC=NO")))  ; Not required
       (inputs
-       `(("bctoolbox" ,bctoolbox)
-         ("mediastreamer2" ,mediastreamer2)
-         ("openh264" ,openh264)
-         ("ortp" ,ortp)))
+       (list bctoolbox mediastreamer2 openh264 ortp))
       (synopsis "Media Streamer H.264 Codec")
       (description "MsOpenH264 is an  H.264 encoder/decoder plugin for
  mediastreamer2 based on the openh264 library.")
@@ -942,9 +933,7 @@ and video calls or instant messaging capabilities to an application.")
          #:configure-flags
          (list "-DENABLE_STATIC=NO")))  ; Not required
       (inputs
-       `(("bctoolbox" ,bctoolbox)
-         ("mediastreamer2" ,mediastreamer2)
-         ("ortp" ,ortp)))
+       (list bctoolbox mediastreamer2 ortp))
       (synopsis "Media Streamer SILK Codec")
       (description "MSSILK is a plugin of MediaStreamer, adding support for AMR
 codec.  It is based on the Skype's SILK implementation.")
@@ -995,9 +984,7 @@ codec.  It is based on the Skype's SILK implementation.")
                "1maqychrgwy0z4zypa03qp726l2finw64z6cymdzhd58ql3p1lvm"))))
          ("python" ,python-wrapper)))
       (inputs
-       `(("bctoolbox" ,bctoolbox)
-         ("mediastreamer2" ,mediastreamer2)
-         ("ortp" ,ortp)))
+       (list bctoolbox mediastreamer2 ortp))
       (synopsis "Media Streamer WebRTC Codec")
       (description "MSWebRTC is a plugin of MediaStreamer, adding support for
 WebRTC codec.  It includes features from WebRTC, such as, iSAC and AECM.")