summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-08 17:52:54 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-15 17:52:44 +0100
commit2b14c60d3870e74f620775ec8dd64634ff874dc7 (patch)
tree5a9149c9e669281fac335cef97bf243a67f6a253 /gnu/packages/linux.scm
parenteaa52b5baa8fbb26a79890561d0c40344d1e1bf3 (diff)
downloadguix-2b14c60d3870e74f620775ec8dd64634ff874dc7.tar.gz
gnu: rdma-core: Use the "write" ioctl mode.
* gnu/packages/linux.scm (rdma-core)[arguments]: Add "-DIOCTL_MODE=write"
to #:configure-flags.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index dd3640e6a8..92c9e7fca3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4322,7 +4322,14 @@ The package provides additional NTFS tools.")
        ;; to do the same for consistency. They also recommend using the
        ;; "Release" build type.
        #:build-type "Release"
-       #:configure-flags (list "-GNinja")
+       #:configure-flags (list "-GNinja"
+
+                               ;; On some configurations, the
+                               ;; IB_USER_MAD_REGISTER_AGENT ioctl, which is
+                               ;; used by default, would return ENODEV.  To
+                               ;; avoid that, use 'write' instead of ioctls,
+                               ;; as suggested in 'CMakeList.txt'.
+                               "-DIOCTL_MODE=write")
        #:phases
        (modify-phases %standard-phases
          (replace 'build