summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-19 12:07:55 +0100
committerMarius Bakke <marius@gnu.org>2022-02-19 12:09:41 +0100
commit68679e7c3e13ac07a881a9c8c26985b20bd6fdb4 (patch)
tree6a386542ae9446a616176c111868a5d1ed57444e /gnu/packages/linux.scm
parentaf50b52ae3dccb89a2210b8609b2b76728c779e9 (diff)
downloadguix-68679e7c3e13ac07a881a9c8c26985b20bd6fdb4.tar.gz
gnu: efibootmgr: Use G-expressions.
* gnu/packages/linux.scm (efibootmgr)[arguments]: Convert to G-expressions.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0ea9474db5..1994aff321 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6770,16 +6770,17 @@ interface to the variable facility of UEFI boot firmware.")
               "efidp_format_device_path((unsigned char *)text_path,"))))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                      ;no tests
-       #:make-flags (list (string-append "prefix=" %output)
-                          (string-append "libdir=" %output "/lib")
-                          ;; EFIDIR denotes a subdirectory relative to the
-                          ;; EFI System Partition where the loader will be
-                          ;; installed (known as OS_VENDOR in the code).
-                          ;; GRUB overrides this, as such it's only used if
-                          ;; nothing else is specified on the command line.
-                          "EFIDIR=gnu")
-       #:phases (modify-phases %standard-phases (delete 'configure))))
+     (list
+      #:tests? #f                       ;no tests
+      #:make-flags #~(list (string-append "prefix=" #$output)
+                           (string-append "libdir=" #$output "/lib")
+                           ;; EFIDIR denotes a subdirectory relative to the
+                           ;; EFI System Partition where the loader will be
+                           ;; installed (known as OS_VENDOR in the code).
+                           ;; GRUB overrides this, as such it's only used if
+                           ;; nothing else is specified on the command line.
+                           "EFIDIR=gnu")
+      #:phases #~(modify-phases %standard-phases (delete 'configure))))
     (native-inputs
      (list pkg-config))
     (inputs