summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 12:36:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 12:36:15 +0100
commit88f9fea72395ea7c00ce4070c1e55f6a82aa7357 (patch)
treea2ed861cf5f22002a929777d32720b14e5e0cd52 /gnu/packages/linux.scm
parent2286107f60e403c8d2f41cc4ba66ed89d14ab762 (diff)
downloadguix-88f9fea72395ea7c00ce4070c1e55f6a82aa7357.tar.gz
gnu: inotify-tools: Fetch sources from git.
* gnu/packages/linux.scm (inotify-tools)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b1dd5adc88..9833ff543d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1967,14 +1967,14 @@ for systems using the Linux kernel.  This includes commands such as
     (name "inotify-tools")
     (version "3.20.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/rvoicilas/inotify-tools/archive/"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rvoicilas/inotify-tools.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1b22c8x4pjnz3abx4dikpbj43zprjw79pdkd4xw111dsxlfwqcx4"))))
+                "14dci1i4mhsd5sa33k8h3ayphk19kizynh5ql9ryibdpmcanfiyq"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases