summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-07-15 17:24:00 +0200
committerLeo Famulari <leo@famulari.name>2024-07-29 23:20:04 -0400
commit93e19067b4428e41c281eebe19746ea253591aad (patch)
treef0ac25da609f2abcf59bdd0630de180d88a4308f /gnu/packages/linux.scm
parent859d1245b4f8953a91a08be79ca91aefb3fb3203 (diff)
downloadguix-93e19067b4428e41c281eebe19746ea253591aad.tar.gz
gnu: Add linux-libre 6.10.1.
* gnu/packages/linux.scm (linux-libre-6.10-version, linux-libre-6.10-gnu-revision,
deblob-scripts-6.10, linux-libre-6.10-pristine-source, linux-libre-6.10-source,
linux-libre-headers-6.10, linux-libre-6.10): New variables.
* gnu/packages/aux-files/linux-libre/6.10-arm.conf,
gnu/packages/aux-files/linux-libre/6.10-arm64.conf,
gnu/packages/aux-files/linux-libre/6.10-i686.conf,
gnu/packages/aux-files/linux-libre/6.10-x86.conf: New files.
* Makefile.am (AUX_FILES): Add them.

Change-Id: If62ec2e8029ebd7531d3b4ba9a666c0b5f3b0f4c
Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ab7425b616..835949158c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -509,6 +509,23 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (sha256 hash)))
 
 
+;; The current "mainline" kernel.
+
+(define-public linux-libre-6.10-version "6.10.1")
+(define-public linux-libre-6.10-gnu-revision "gnu")
+(define deblob-scripts-6.10
+  (linux-libre-deblob-scripts
+   linux-libre-6.10-version
+   linux-libre-6.10-gnu-revision
+   (base32 "1j43v1z4g1f681wvna2dh9vxaz0pgni0wchbh1xhyhhfcqbm1f47")
+   (base32 "00bx8g1ijswi9zypmwqhxsk9fdkzmarxdbdx5h6gpn7z4d1qly3j")))
+(define-public linux-libre-6.10-pristine-source
+  (let ((version linux-libre-6.10-version)
+        (hash (base32 "0szpkhrwfqwj068vz032daf3zycv5c93gjxiisjziifi3kyrs43h")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-6.10)))
+
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
 
@@ -650,6 +667,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-6.10-source
+  (source-with-patches linux-libre-6.10-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
 (define-public linux-libre-6.9-source
   (source-with-patches linux-libre-6.9-pristine-source
                        (list %boot-logo-patch
@@ -770,6 +792,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-6.10
+  (make-linux-libre-headers* linux-libre-6.10-version
+                             linux-libre-6.10-gnu-revision
+                             linux-libre-6.10-source))
+
 (define-public linux-libre-headers-6.9
   (make-linux-libre-headers* linux-libre-6.9-version
                              linux-libre-6.9-gnu-revision
@@ -1146,6 +1173,14 @@ Linux kernel.  It has been modified to remove all non-free binary blobs.")
 (define-public linux-libre-source          linux-libre-6.9-source)
 (define-public linux-libre                 linux-libre-6.9)
 
+(define-public linux-libre-6.10
+  (make-linux-libre* linux-libre-6.10-version
+                     linux-libre-6.10-gnu-revision
+                     linux-libre-6.10-source
+                     '("x86_64-linux" "i686-linux" "armhf-linux"
+                       "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-6.6
   (make-linux-libre* linux-libre-6.6-version
                      linux-libre-6.6-gnu-revision