summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-26 18:55:06 -0400
committerLeo Famulari <leo@famulari.name>2021-05-08 18:41:45 -0400
commita21355bd1008d9f71dfb8ec6f4fdb33cf3a5007f (patch)
tree849d9e378d01d77bb63b70f61c0f8a78cd5da712 /gnu/packages/linux.scm
parentd2a265b08e9cc85465fdd83e9f453b2bf0a40026 (diff)
downloadguix-a21355bd1008d9f71dfb8ec6f4fdb33cf3a5007f.tar.gz
gnu: Add linux-libre 5.12.2.
* gnu/packages/linux.scm (linux-libre-5.12-version, deblob-scripts-5.12,
linux-libre-5.12-pristine-source, linux-libre-5.12-source,
linux-libre-headers-5.12, linux-libre-5.12): New variables.
* gnu/packages/aux-files/linux-libre/5.12-arm.conf,
gnu/packages/aux-files/linux-libre/5.12-arm64.conf,
gnu/packages/aux-files/linux-libre/5.12-i686.conf,
gnu/packages/aux-files/linux-libre/5.12-x86_64.conf: New files.
* Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 96f301995c..9b3c90e375 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -356,6 +356,19 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
 
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
+(define-public linux-libre-5.12-version "5.12.2")
+(define deblob-scripts-5.12
+  (linux-libre-deblob-scripts
+   linux-libre-5.12-version
+   (base32 "1vdsr9y4gckknrbqcjyfakwva3k0vb5zcivzk3k1s9mh7qp9dils")
+   (base32 "1qp25fd4wgjyk7dzdq9yirm1z5w68sd1p3wv8lch8259i51gwjnf")))
+(define-public linux-libre-5.12-pristine-source
+  (let ((version linux-libre-5.12-version)
+        (hash (base32 "03gp5vq8vkwvksjsa1birds37rmrr73s9ik6m1wvgz8mdncvk64c")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-5.12)))
+
 (define-public linux-libre-5.11-version "5.11.18")
 (define deblob-scripts-5.11
   (linux-libre-deblob-scripts
@@ -478,6 +491,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-5.12-source
+  (source-with-patches linux-libre-5.12-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
 (define-public linux-libre-5.11-source
   (source-with-patches linux-libre-5.11-pristine-source
                        (list %boot-logo-patch
@@ -592,6 +610,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-5.12
+  (make-linux-libre-headers* linux-libre-5.12-version
+                             linux-libre-5.12-source))
+
 (define-public linux-libre-headers-5.11
   (make-linux-libre-headers* linux-libre-5.11-version
                              linux-libre-5.11-source))
@@ -890,6 +912,12 @@ It has been modified to remove all non-free binary blobs.")
 ;;; Generic kernel packages.
 ;;;
 
+(define-public linux-libre-5.12
+  (make-linux-libre* linux-libre-5.12-version
+                     linux-libre-5.12-source
+                     '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-5.11
   (make-linux-libre* linux-libre-5.11-version
                      linux-libre-5.11-source