summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-27 17:30:30 -0500
committerLeo Famulari <leo@famulari.name>2023-03-06 18:15:06 -0500
commitad66469b240cdf487b6deddff145ccc7091ca529 (patch)
tree4a7bde50a2e6921df6b17d2f318e3975c4dd22f3 /gnu/packages/linux.scm
parent0d963875278d585eb86bc87127efa20a8d627595 (diff)
downloadguix-ad66469b240cdf487b6deddff145ccc7091ca529.tar.gz
gnu: Fix kernel source infodoc patching for linux-libre >= 6.2.
* gnu/packages/linux.scm (doc-supported?): Rename to ...
(apply-infodoc-patch?): ... new variable with different kernel version
constraints.
(make-linux-libre): Adjust accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 747e414e6d..e3acaeb60b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -863,10 +863,12 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
 ;;; Kernel package utilities.
 ;;;
 
-(define (doc-supported? version)
+(define (apply-infodoc-patch? version)
   ;; Versions older than 5.10 have different enough build scripts that the
   ;; infodocs patch doesn't apply.
-  (version>=? version "5.10"))
+  (and (version>=? version "5.10")
+       (not (version>=? version "6.2")))) ;patch applied upstream
+
 
 (define* (make-linux-libre version gnu-revision hash-string supported-systems
                            #:key
@@ -879,7 +881,7 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
                            (extra-options %default-extra-linux-options)
                            (patches
                             `(,%boot-logo-patch
-                              ,@(if (doc-supported? version)
+                              ,@(if (apply-infodoc-patch? version)
                                     (list (search-patch
                                            "linux-libre-infodocs-target.patch"))
                                     '()))))