summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:53:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:54:06 +0100
commitc961057bf67f0d92ea4a4b3956f00c14150c4778 (patch)
treed63006cbc623fc7222232184d3942cdd0d8b88f1 /gnu/packages/linux.scm
parent0a6eb07ad92f815cf6316298636d983544b8fa79 (diff)
downloadguix-c961057bf67f0d92ea4a4b3956f00c14150c4778.tar.gz
gnu: go-netlink: Refresh package style.
* gnu/packages/linux.scm (go-netlink): Fix indentation, apply new
package style, swap native-inputs with propagated-inputs.
[propagated-inputs]: Add go-golang-org-x-sys and go-github-com-vishvananda-netns.
[native-inputs]: Remove go-golang-org-x-sys and go-github-com-vishvananda-netns.

Change-Id: I523cd03263752ab00c08e9011b86cb1b64327e7f
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1fe8da839c..40c14745fa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9293,27 +9293,29 @@ management tools in userspace.")
   (package
     (name "go-netlink")
     (version "1.1.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/vishvananda/netlink")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1vhl30p1gx636a088ls4h6a0l8jjyfvz79fr5w0qzdrg4qg9h08h"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vishvananda/netlink")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vhl30p1gx636a088ls4h6a0l8jjyfvz79fr5w0qzdrg4qg9h08h"))))
     (build-system go-build-system)
     (arguments
-     `(#:tests? #f      ; Tests depend on specific kernel modules.
-       #:import-path "github.com/vishvananda/netlink"))
-    (native-inputs
+     (list
+      #:tests? #f      ; Tests depend on specific kernel modules.
+      #:import-path "github.com/vishvananda/netlink"))
+    (propagated-inputs
      (list go-golang-org-x-sys go-github-com-vishvananda-netns))
     (home-page "https://github.com/vishvananda/netlink")
     (synopsis "Simple netlink library for Go")
-    (description "The netlink package provides a simple netlink library for
-Go.  Netlink is the interface a user-space program in Linux uses to
-communicate with the kernel.  It can be used to add and remove interfaces, set
-IP addresses and routes, and configure IPsec.")
+    (description
+     "The netlink package provides a simple netlink library for Go.  Netlink
+is the interface a user-space program in Linux uses to communicate with the
+kernel.  It can be used to add and remove interfaces, set IP addresses and
+routes, and configure IPsec.")
     (license license:asl2.0)))
 
 (define-public libinih