summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-11 12:52:43 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-11 13:03:23 +0200
commitcef0e08c235d1eb9943571648ef57a59041bb292 (patch)
treeb5b04cd92f3cfd69354f906de9d57cf012d82015 /gnu/packages/linux.scm
parentf69cf40741f6ba4e79a5e8f6dae407d96f4433ec (diff)
downloadguix-cef0e08c235d1eb9943571648ef57a59041bb292.tar.gz
gnu: proot: Fix test failures.
The upgrade to Make 4.3 and Coreutils 8.30 introduced test failures that
this commit addresses.

* gnu/packages/base.scm (coreutils-8.30): New variable.
* gnu/packages/linux.scm (proot)[native-inputs]: Add COREUTILS-8.30 and
GNU-MAKE-4.2.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c429b05cff..7cf7521e24 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6099,7 +6099,16 @@ userspace queueing component and the logging subsystem.")
     (native-inputs `(("which" ,which)
 
                      ;; For 'mcookie', used by some of the tests.
-                     ("util-linux" ,util-linux)))
+                     ("util-linux" ,util-linux)
+
+                     ;; XXX: Choose the old coreutils because its 'stat'
+                     ;; program does not use statx(2) when running 'stat -c
+                     ;; %a' or similar, which PRoot doesn't properly support.
+                     ("coreutils-old" ,coreutils-8.30)
+
+                     ;; XXX: 'test-c6b77b77.sh' runs 'make' and that leads
+                     ;; make 4.3 to segfault.
+                     ("make-old" ,gnu-make-4.2)))
     (inputs `(("talloc" ,talloc)))
     (home-page "https://github.com/proot-me/PRoot")
     (synopsis "Unprivileged chroot, bind mount, and binfmt_misc")