summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-01-06 16:57:10 +0800
committerHilton Chain <hako@ultrarare.space>2024-01-25 23:49:37 +0800
commited7eb108e5ba38135db99aa3b162f88797c372f9 (patch)
tree0e5ae5212971c2de2b414a04e5fb9059b863448f /gnu/packages/linux.scm
parent0252d69f911a5726a32695e6e57f3922c3414980 (diff)
downloadguix-ed7eb108e5ba38135db99aa3b162f88797c372f9.tar.gz
gnu: libcgroup: Update to 3.1.0.
* gnu/packages/linux.scm (libcgroup): Update to 3.1.0.
[arguments]<#:configure-flags>: Disable systemd.

Change-Id: Iabd8577243b741380fa0d69811fcbf8ad551ddb2
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 21ba422b55..88d36a1ca2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8799,7 +8799,7 @@ framebuffer dump file (copy) to a PNG image.")
 (define-public libcgroup
   (package
     (name "libcgroup")
-    (version "2.0.2")
+    (version "3.1.0")
     (home-page "https://github.com/libcgroup/libcgroup")
     (source
      (origin
@@ -8808,14 +8808,16 @@ framebuffer dump file (copy) to a PNG image.")
              "https://github.com/libcgroup/libcgroup/releases/download/v"
              version "/" name "-" version ".tar.gz"))
        (sha256
-        (base32 "1y0c9ncsawamj77raiw6qkbm5cdsyvhjb2mvgma1kxmgw0r3pxlf"))))
+        (base32 "0n0jkvmagw14vgwx3j5b6vv5h25lasrg2a7xihq9h11ww2qw8vlp"))))
     (build-system gnu-build-system)
     (arguments
      ;; Tests are virtualized with lxc, it is not very feasible
      ;; to make them executable under guix build. Also, note that
      ;; origin is using source tarball release which is prepared
      ;; after testing.
-     `(#:tests? #f))
+     (list #:tests? #f
+           #:configure-flags
+           #~'("--disable-systemd")))
     (native-inputs
      (list bison flex))
     (inputs