summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-04-12 15:08:08 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-12 15:08:08 +0200
commit59377f88ed1e31d38b34279f393949bf17e505ad (patch)
treedc05fefa0193a25a241bd30c19e000bd3a4d55be /gnu/packages/lisp-xyz.scm
parent917c25b3ba0575c6c6e44f8af0d1365bb2378220 (diff)
downloadguix-59377f88ed1e31d38b34279f393949bf17e505ad.tar.gz
gnu: cl-py4cl: Improve package definition.
This is a follow-up to 917c25b3ba0575c6c6e44f8af0d1365bb2378220.

* gnu/packages/lisp-xyz.scm (sbcl-py4cl)[propagated-inputs]: Move python
  to...
  [inputs]: ... here.
  [arguments]: Use 'search-input-file' instead of 'which' in
  'fix-python3-path' phase.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0065f56e7e..75b299152a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5172,21 +5172,21 @@ port within a range.")
       (native-inputs
        (list sbcl-clunit))
       (inputs
-       (list sbcl-trivial-garbage))
+       (list python sbcl-trivial-garbage))
       (propagated-inputs
-       ;; This package doesn't do anything without python available
-       (list python
-             ;; For multi-dimensional array support
+       (list ;; For multi-dimensional array support
              python-numpy))
       (arguments
        '(#:phases
          (modify-phases %standard-phases
            (add-after 'unpack 'fix-python3-path
-             (lambda _
+             (lambda* (#:key inputs #:allow-other-keys)
                (substitute* "src/callpython.lisp"
                  (("\\*python-command\\* \"python\"")
                   (string-append "*python-command* "
-                                 "\"" (which "python3") "\"")))))
+                                 "\""
+                                 (search-input-file inputs "/bin/python3")
+                                 "\"")))))
            (add-after 'unpack 'replace-*base-directory*-var
              (lambda* (#:key outputs #:allow-other-keys)
                ;; In the ASD, the author makes an attempt to