summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-16 23:23:17 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-17 10:18:38 +0100
commitfc284b733e3aa9f387219890c90c737e652f3843 (patch)
tree8f6b94a1c4abfec8a007bdf403021576be0fb2df /gnu/packages/lisp-xyz.scm
parent81c1d127aeb16d6ee0eece6d6ed6b194019b2ea6 (diff)
downloadguix-fc284b733e3aa9f387219890c90c737e652f3843.tar.gz
gnu: cl-change-case: Update to 0.2.0-1.45c70b6.
* gnu/packages/lisp-xyz.scm (sbcl-cl-change-case): Update to 0.2.0-1.45c70b6.
  [arguments] Enable tests.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6a070b5b51..390db119a5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10195,10 +10195,11 @@ multiple checkers, including Aspell and Hunspell.")
   (sbcl-package->ecl-package sbcl-enchant))
 
 (define-public sbcl-cl-change-case
-  (let ((commit "5ceff2a5f8bd845b6cb510c6364176b27a238fd3"))
+  (let ((commit "45c70b601125889689e0c1c37d7e727a3a0af022")
+        (revision "1"))
     (package
       (name "sbcl-cl-change-case")
-      (version (git-version "0.1.0" "1" commit))
+      (version (git-version "0.2.0" revision commit))
       (home-page "https://github.com/rudolfochrist/cl-change-case")
       (source
        (origin
@@ -10208,18 +10209,13 @@ multiple checkers, including Aspell and Hunspell.")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "1afyglglk9z3yg8gylcl301bl2r8vq3sllyznzj9s5xi5gs6qyf2"))))
+          (base32 "0qmk341zzcsbf8sq0w9ix3r080zg4ri6vzxym63lhdjfzwz3y8if"))))
       (build-system asdf-build-system/sbcl)
       (inputs
        `(("cl-ppcre" ,sbcl-cl-ppcre)
          ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)))
       (native-inputs
        `(("fiveam" ,sbcl-fiveam)))
-      (arguments
-       '(;; FIXME: Test pass but phase fails with 'Component
-         ;; "cl-change-case-test" not found, required by'.
-         #:tests? #f
-         #:test-asd-file "cl-change-case-test.asd"))
       (synopsis "Convert Common Lisp strings between camelCase, PascalCase and more")
       (description
        "@code{cl-change-case} is library to convert strings between camelCase,