summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-09-16 15:32:41 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-18 11:55:42 +0200
commited0ddadcd59c88c182e2a6e1b58b4b1c5f6f7273 (patch)
treeb11ade7a5ca68bffb83f9f9187dcc1a3e24fa6f8 /gnu/packages/lisp.scm
parent76b66fbaf5881ceeea0e75693ffb6678f35fe6ed (diff)
downloadguix-ed0ddadcd59c88c182e2a6e1b58b4b1c5f6f7273.tar.gz
gnu: Add cl-octet-streams.
* gnu/packages/lisp.scm (sbcl-cl-octet-streams, cl-octet-streams,
  ecl-cl-octet-streams): New variables.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 205a6120be..63381a8cea 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7282,3 +7282,36 @@ can contain any kind of values.")
 
 (define-public ecl-bst
   (sbcl-package->ecl-package sbcl-bst))
+
+(define-public sbcl-cl-octet-streams
+  (package
+    (name "sbcl-cl-octet-streams")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/glv2/cl-octet-streams.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1d7mn6ydv0j2x4r7clpc9ijjwrnfpxmvhifv8n5j7jh7s744sf8d"))))
+    (build-system asdf-build-system/sbcl)
+    (native-inputs
+     `(("fiveam" ,sbcl-fiveam)))
+    (inputs
+     `(("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+    (synopsis "In-memory octet streams for Common Lisp")
+    (description
+     "CL-octet-streams is a library implementing in-memory octet
+streams for Common Lisp.  It was inspired by the trivial-octet-streams and
+cl-plumbing libraries.")
+    (home-page "https://github.com/glv2/cl-octet-streams")
+    (license license:gpl3+)))
+
+(define-public cl-octet-streams
+  (sbcl-package->cl-source-package sbcl-cl-octet-streams))
+
+(define-public ecl-cl-octet-streams
+  (sbcl-package->ecl-package sbcl-cl-octet-streams))