summary refs log tree commit diff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-11-07 19:47:42 +0000
committerLudovic Courtès <ludo@gnu.org>2022-11-11 23:17:43 +0100
commit8f8000a95f6753d495cbb1fa3cd38a2a92de937d (patch)
treea516c2625645994fcbe6b732d8b84b4c10f82a5b /gnu/packages/logging.scm
parent474070facbb6c718788b8e9ba7abcc473804d8f4 (diff)
downloadguix-8f8000a95f6753d495cbb1fa3cd38a2a92de937d.tar.gz
gnu: Add spdlog-1.10.
* gnu/packages/logging.scm (spdlog-1.10): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 2781ac5194..7cce8e1624 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -245,6 +245,20 @@ library.")
     ;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
     (license (list license:expat license:bsd-2))))
 
+(define-public spdlog-1.10
+  (package
+    (inherit spdlog)
+    (version "1.10.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gabime/spdlog")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name "spdlog" version))
+       (sha256
+        (base32 "02xz017ba9fssm1rp1fcfld7h79awbr6fqai9dxaqp02akp3davk"))))))
+
 (define-public rsyslog
   (package
     (name "rsyslog")