summary refs log tree commit diff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 03:52:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 05:44:10 +0100
commit70303d073a4f9e9d9fdfa309c6fc350e80b63a60 (patch)
tree02b7e0163abec8bf255db7368232b9d30eb8b1a3 /gnu/packages/lsof.scm
parent518b21e058f9ccf23257a2afe1bbace280c5fe1d (diff)
downloadguix-70303d073a4f9e9d9fdfa309c6fc350e80b63a60.tar.gz
gnu: lsof: Respect #:tests?.
* gnu/packages/lsof.scm (lsof)[arguments]: The 'check phase takes and
respects a TESTS? keyword.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index ad3dfbd2df..0421ca7e9d 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -79,15 +79,16 @@
               (("(OPTTST=.*) LTnfs"  _ prefix) prefix))
             #t))
         (replace 'check
-          (lambda _
-            (with-directory-excursion "tests"
-              ;; Tests refuse to run on ‘unvalidated’ platforms.
-              (make-file-writable "TestDB")
-              (invoke "./Add2TestDB")
+          (lambda* (#:key tests? #:allow-other-keys)
+            (when tests?
+              (with-directory-excursion "tests"
+                ;; Tests refuse to run on ‘unvalidated’ platforms.
+                (make-file-writable "TestDB")
+                (invoke "./Add2TestDB")
 
-              ;; The ‘standard’ tests suggest running ‘optional’ ones as well.
-              (invoke "make" "standard" "optional")
-              #t)))
+                ;; The ‘standard’ tests suggest running ‘optional’ ones as well.
+                (invoke "make" "standard" "optional")))
+            #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))