summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-05-17 00:05:48 +1000
committerLudovic Courtès <ludo@gnu.org>2021-05-29 20:16:46 +0200
commit64f28a62b20af3d73aa81cd4b5974c744bef1f16 (patch)
tree926c03f69f43e0e4affbdf320dbcfe3584f8c3b9 /gnu/packages/lxqt.scm
parent1ae280cd5e7ea58946ac526dde4c6ca846eaf023 (diff)
downloadguix-64f28a62b20af3d73aa81cd4b5974c744bef1f16.tar.gz
gnu: lxqt-build-tools: Update to 0.9.0.
* gnu/packages/lxqt.scm (lxqt-build-tools): Update to 0.9.0.
[propagated-inputs]: Add perl. dependent projects require it via the
CMake files.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 6ca7b473dc..b7c001868f 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -128,7 +128,7 @@ to statistics about the system on which it's run.")
 (define-public lxqt-build-tools
   (package
     (name "lxqt-build-tools")
-    (version "0.7.0")
+    (version "0.9.0")
     (source
      (origin
        (method url-fetch)
@@ -136,7 +136,7 @@ to statistics about the system on which it's run.")
                            "/download/" version
                            "/lxqt-build-tools-" version ".tar.xz"))
        (sha256
-        (base32 "147vdkc25mrlr0fy785yzwhm4gwjxa5xl3n3hljz4c97m531kzl5"))))
+        (base32 "0kayad5l72h8n90zkf3hy8fxy72n4b1mrkjglpa9dj0cdj6qg0lp"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -151,6 +151,9 @@ to statistics about the system on which it's run.")
        ("glib" ,glib)))
     (inputs
      `(("qtbase" ,qtbase)))
+    (propagated-inputs
+     ;; Dependent projects require Perl via the CMake files.
+     `(("perl" ,perl)))
     (synopsis "LXQt Build tools")
     (description
      "Lxqt-build-tools is providing several tools needed to build LXQt