summary refs log tree commit diff
path: root/gnu/packages/m4.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-25 00:38:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-25 00:39:19 +0200
commit1fa49a2c4636c0f35972c16f6bd2d28a4424b821 (patch)
tree618ded9693b8d28541667762c19921f04a902edc /gnu/packages/m4.scm
parent5608847c6f4131e8f30321fdf25289efd73f8689 (diff)
downloadguix-1fa49a2c4636c0f35972c16f6bd2d28a4424b821.tar.gz
gnu: m4: Upgrade to 1.4.17.
* gnu/packages/m4.scm (m4): Upgrade to 1.4.17.  Remove
  'm4-s_isdir.patch' and 'm4-gets-undeclared.patch'.
* gnu/packages/patches/m4-s_isdir.patch: Remove.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/m4.scm')
-rw-r--r--gnu/packages/m4.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/m4.scm b/gnu/packages/m4.scm
index 0be1824382..17ca7c8440 100644
--- a/gnu/packages/m4.scm
+++ b/gnu/packages/m4.scm
@@ -26,14 +26,14 @@
 (define-public m4
   (package
    (name "m4")
-   (version "1.4.16")
+   (version "1.4.17")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/m4/m4-"
                                 version ".tar.bz2"))
             (sha256
              (base32
-              "035r7ma272j2cwni2961jp22k6bn3n9xwn3b3qbcn2yrvlghql22"))))
+              "0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))))
    (build-system gnu-build-system)
    (arguments
     ;; XXX: Disable tests on those platforms with know issues.
@@ -41,10 +41,8 @@
                              '("x86_64-darwin"
                                "i686-cygwin"
                                "i686-sunos")))
-      #:patches (list (assoc-ref %build-inputs "patch/s_isdir")
-                      (assoc-ref %build-inputs
-                                 "patch/readlink-EINVAL")
-                      (assoc-ref %build-inputs "patch/gets"))
+      #:patches (list (assoc-ref %build-inputs
+                                 "patch/readlink-EINVAL"))
       #:phases (alist-cons-before
                 'check 'pre-check
                 (lambda* (#:key inputs #:allow-other-keys)
@@ -57,10 +55,8 @@
                       (("/bin/sh")
                        (format #f "~a/bin/bash" bash)))))
                 %standard-phases)))
-   (inputs `(("patch/s_isdir" ,(search-patch "m4-s_isdir.patch"))
-             ("patch/readlink-EINVAL"
-              ,(search-patch "m4-readlink-EINVAL.patch"))
-             ("patch/gets" ,(search-patch "m4-gets-undeclared.patch"))))
+   (inputs `(("patch/readlink-EINVAL"
+              ,(search-patch "m4-readlink-EINVAL.patch"))))
    (synopsis "Macro processor")
    (description
     "GNU M4 is an implementation of the traditional Unix macro processor.  It