summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-20 02:08:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-21 16:34:26 +0100
commit0ef7ea66b9d10e70a6e09a0e0e13811ceb99ee65 (patch)
treeefa62de6bf540a88e9331de104becdaf4d1e5d82 /gnu/packages/machine-learning.scm
parent025519fa955cd554dd9c868b996b1dc6ba54f4a7 (diff)
downloadguix-0ef7ea66b9d10e70a6e09a0e0e13811ceb99ee65.tar.gz
gnu: dlib: Update to 19.2.
* gnu/packages/machine-learning.scm (dlib): Update to 19.2.
[arguments]: Enable previously failing tests. Fix truthiness of some phases.
[source]: End snippet on #t.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 8f1f8ee53b..7ed12e677a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -504,20 +504,21 @@ and a QP solver.")
 (define-public dlib
   (package
     (name "dlib")
-    (version "19.1")
+    (version "19.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "http://dlib.net/files/dlib-" version ".tar.bz2"))
               (sha256
                (base32
-                "0p2pvcdalc6jhb6r99ybvjd9x74sclr0ngswdg9j2xl5pj7knbr4"))
+                "0jh840b3ynlqsvbpswzg994yk539zbhx2sk6lybd23qyd2b8zgi8"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   ;; Delete ~13MB of bundled dependencies.
                   (delete-file-recursively "dlib/external")
-                  (delete-file-recursively "docs/dlib/external")))))
+                  (delete-file-recursively "docs/dlib/external")
+                  #t))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
@@ -532,8 +533,7 @@ and a QP solver.")
          (add-after 'disable-asserts 'disable-failing-tests
            (lambda _
              ;; One test times out on MIPS, so we need to disable it.
-             ;; The rest is known to fail on non-x86_64 platforms in the current release.
-             ;; Some have been fixed in git; this list should be readjusted next update.
+             ;; Others are flaky on some platforms.
              (let* ((system ,(or (%current-target-system)
                                  (%current-system)))
                     (disabled-tests (cond
@@ -543,15 +543,14 @@ and a QP solver.")
                                      ((string-prefix? "armhf" system)
                                       '("learning_to_track" "max_cost_assignment"))
                                      ((string-prefix? "i686" system)
-                                      '("optimization" "matrix2" "mpc"))
+                                      '("optimization"))
                                      (else '()))))
-               ;; The following test fails due a bug in openblas < 0.2.18.
-               (append! disabled-tests '("empirical_map"))
                (for-each
                 (lambda (test)
                   (substitute* "dlib/test/makefile"
-                    (((string-append "SRC \\+= " test "\\.cpp")) "")) #t)
-                disabled-tests))))
+                    (((string-append "SRC \\+= " test "\\.cpp")) "")))
+                disabled-tests)
+               #t)))
          (replace 'check
            (lambda _
              ;; No test target, so we build and run the unit tests here.
@@ -562,7 +561,9 @@ and a QP solver.")
                       (zero? (system* "./dtest" "--runall")))))))
          (add-after 'install 'delete-static-library
            (lambda* (#:key outputs #:allow-other-keys)
-             (delete-file (string-append (assoc-ref outputs "out") "/lib/libdlib.a")))))))
+             (delete-file (string-append (assoc-ref outputs "out")
+                                         "/lib/libdlib.a"))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs