summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 15:28:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:34 +0100
commitca1749c243f7ac81adb31c0589f87367eb4021dd (patch)
treea83269fa8f95e83d888584914b39cc9b69843680 /gnu/packages/machine-learning.scm
parent247c427302daebf59a23b18d24a6bb0e9bbd906e (diff)
downloadguix-ca1749c243f7ac81adb31c0589f87367eb4021dd.tar.gz
gnu: python-pynndescent: Update to 0.5.11.
* gnu/packages/machine-learning.scm (python-pynndescent): Update to 0.5.11.
[build-system]: Use pyproject-build-system.
[arguments]: Remove.
[propagated-inputs]: Add python-importlib-metadata.

Change-Id: I14f15ea98157ed15b360971c30fe00c5f00af4a7
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 5 insertions, 14 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index af55a99152..95d057662d 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1824,27 +1824,18 @@ It is compatible with @code{scikit-learn}.")
 (define-public python-pynndescent
   (package
     (name "python-pynndescent")
-    (version "0.5.10")
+    (version "0.5.11")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pynndescent" version))
        (sha256
-        (base32 "1bc8aa6jfw28y6sb0nvfdrfgh66a42bqb4znvpimzx9yq21wcpax"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (invoke "python" "-m" "pytest" "--pyargs" "pynndescent"
-                       ;; wminkowski no longer exists in scipy 1.8.0 (see:
-                       ;; https://github.com/lmcinnes/pynndescent/issues/177)
-                       "-k" "not test_weighted_minkowski")))))))
+        (base32 "0l5dpdsk5vg7rpay81bncp04119hnl5z7zxjv63jrnm9spcwwi3g"))))
+    (build-system pyproject-build-system)
     (native-inputs (list python-pytest))
     (propagated-inputs
-     (list python-joblib
+     (list python-importlib-metadata
+           python-joblib
            python-llvmlite
            python-numba
            python-scikit-learn