summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-11-18 00:56:59 +0100
committerArun Isaac <arunisaac@systemreboot.net>2023-11-20 18:52:09 +0000
commitd20ece07dbb09382f361c8bbf0bcab9e83d8b73e (patch)
treed6fccbc37a24109bc1434002f989fb37288e57e0 /gnu/packages/machine-learning.scm
parentee49611771e73aebcab92972b856dc91761ac77f (diff)
downloadguix-d20ece07dbb09382f361c8bbf0bcab9e83d8b73e.tar.gz
gnu: python-imbalanced-learn: Update to 0.11.0.
* gnu/packages/machine-learning.scm (python-imbalanced-learn): Update to
0.11.0.
[arguments]<#:test-flags>: Move broken tests from "unbreak-tests" phase to
here.
<#:phases>: Add back some deleted python-keras and tensorflow tests.
[native-inputs]: Add python-keras, python-numpydoc and tensorflow.

Change-Id: Ibc2827e27ee23e0ffb491cb791bba4d1a3f1109d
Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index b5bf9aa5fe..7d833005bc 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1663,39 +1663,38 @@ and forecasting.")
 (define-public python-imbalanced-learn
   (package
     (name "python-imbalanced-learn")
-    (version "0.9.1")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "imbalanced-learn" version))
        (sha256
-        (base32 "0qnrmysnqpc8ii1w5n8mci20gcjhmjr7khvk7f2apdbqc2pgf52f"))))
+        (base32 "1p4gdgc8nsq0vjmw4y4d2bp9g0m1c23d0zgrzs90pnz6b24ax0km"))))
     (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags '(list "-k"
+                     ;; Although we cannot satify the Tensorflow and Keras requirements
+                     ;; (python-keras >= 2.4.3 and tensorflow >= 2.4.3), all tests
+                     ;; besides these pass.
+                     "not balanced_batch_generator and not BalancedBatchGenerator")
       #:phases '(modify-phases %standard-phases
                   (add-after 'unpack 'unbreak-tests
                     (lambda _
-                      ;; The doctests require tensorflow
-                      (substitute* "setup.cfg"
-                        (("--doctest-modules")
-                         ""))
                       ;; Some tests require a home directory
                       (setenv "HOME"
-                              (getcwd))
-                      ;; We don't have keras
-                      (delete-file "imblearn/keras/tests/test_generator.py")
-                      ;; We don't have tensorflow
-                      (delete-file
-                       "imblearn/tensorflow/tests/test_generator.py"))))))
+                              (getcwd)))))))
     (propagated-inputs (list python-joblib python-numpy python-scikit-learn
                              python-scipy python-threadpoolctl))
     (native-inputs (list python-black
                          python-flake8
+                         python-keras
                          python-mypy
+                         python-numpydoc
                          python-pandas
                          python-pytest
-                         python-pytest-cov))
+                         python-pytest-cov
+                         tensorflow))
     (home-page "https://github.com/scikit-learn-contrib/imbalanced-learn")
     (synopsis "Toolbox for imbalanced dataset in machine learning")
     (description