summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-26 22:36:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 00:49:22 +0200
commit996aca2852b97570988eb6d7371f15fcedd16e46 (patch)
treecc50586736ba4e830f628951dfd11a8f517be6d9 /gnu/packages/mail.scm
parentce1178d5d30f4525f636e8679cf514001c36291b (diff)
downloadguix-996aca2852b97570988eb6d7371f15fcedd16e46.tar.gz
gnu: opensmtpd-next: Update to 6.6.0p1.
* gnu/packages/mail.scm (opensmtpd-next): Update to 6.6.0p1.
[inputs]: Replace openssl with libressl.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9e8b778c73..2c6192ca01 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2269,20 +2269,22 @@ e-mails with other systems speaking the SMTP protocol.")
 (define-public opensmtpd-next
   (package
     (name "opensmtpd-next")
-    (version "6.4.2p1")
+    (version "6.6.0p1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.opensmtpd.org/archives/"
                            "opensmtpd-" version ".tar.gz"))
        (sha256
-        (base32 "0pgv080ai7d98l9340jadp9wjiaqj2qvgpqhilcz0kps2mdiawbd"))))
+        (base32 "1sgwbvc28h9nyyj4lv8d9b4ilzz03p2j1j763yr759k336a2193m"))))
     (build-system gnu-build-system)
     (inputs
      `(("bdb" ,bdb)
        ("libasr" ,libasr)
        ("libevent" ,libevent)
-       ("libressl" ,libressl)
+       ;; XXX Upstream recommends LibreSSL, which doesn't support TLS 1.3 yet,
+       ;; and requires a development release (3.0.2).  Use OpenSSL instead.
+       ("openssl" ,openssl)
        ("linux-pam" ,linux-pam)
        ("zlib" ,zlib)))
     (native-inputs