summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-13 14:52:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 14:52:37 +0100
commite06b1ebcaa19dc80016d7ebff05d590a829dd930 (patch)
tree19f50db114a67e5d33c1ba9257767361732a5c2a /gnu/packages/mail.scm
parent80a4b150fc6b8d8a387744f1957979c95240f79d (diff)
downloadguix-e06b1ebcaa19dc80016d7ebff05d590a829dd930.tar.gz
gnu: Add l2md.
* gnu/packages/mail.scm (l2md): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f81674a5a2..b02f547e03 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -58,6 +58,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages mail)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages aspell)
@@ -3924,6 +3925,45 @@ It is a replacement for the @command{urlview} program.")
 related tools to process winmail.dat files.")
     (license license:gpl2+)))
 
+(define-public l2md
+  ;; No official release.
+  (let ((commit "f7286b49bb5fce25c898c143712fe34ad4d7864e")
+        (revision "1"))
+    (package
+      (name "l2md")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.kernel.org/pub/scm/linux/kernel/git/dborkman/l2md.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0hxz8i70v1xgv30zjclfvmjqszn073c7i8nwmswi2lr6vd7cklvp"))))
+      (build-system gnu-build-system)
+      (inputs
+       `(("libgit2" ,libgit2)))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (delete 'configure)          ;no configure scripts
+           (delete 'check)              ;no tests
+           (add-before 'install 'mkdir
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((l2md (string-append (assoc-ref outputs "out") "/bin")))
+                 (mkdir-p l2md)))))
+         #:make-flags
+         (list ,(string-append "CC=" (cc-for-target))
+               (string-append "PREFIX=" %output "/bin"))))
+      (home-page
+       "https://git.kernel.org/pub/scm/linux/kernel/git/dborkman/l2md.git")
+      (synopsis "Import public-inbox archives via Git")
+      (description
+       "The @command{l2md} command line tool imports public-inbox archives via
+Git and exports them in maildir format or to an MDA through a pipe.")
+      (license license:gpl2))))
+
 (define-public public-inbox
   (package
     (name "public-inbox")