summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-07-17 20:29:50 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-07-26 08:18:46 +0200
commitff4192ff5783855b025093c6e5cf133efb60943b (patch)
tree96dbec4761723279b36b11d32759d2c30bfe77e1 /gnu/packages/mail.scm
parent8ad40a69d16d33cb307cd2a7762ac8ea807bfb92 (diff)
downloadguix-ff4192ff5783855b025093c6e5cf133efb60943b.tar.gz
gnu: claws-mail: Disable (duplicate) Gtk+ icon cache generation.
* gnu/packages/mail.scm (claws-mail)[arguments]: Add make-flags to disable
Gtk+ icon cache generation.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 157a33f45d..cc76a93ed0 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -930,6 +930,11 @@ compresses it.")
     (arguments
       '(#:configure-flags
         '("--enable-gnutls" "--enable-pgpmime-plugin" "--enable-enchant")
+        #:make-flags
+        ;; Disable updating icon cache since it's done by the profile hook.
+        ;; Conflict with other packages in the profile would be inevitable
+        ;; otherwise.
+        '("gtk_update_icon_cache=true")
         #:phases (modify-phases %standard-phases
                    (add-before 'build 'patch-mime
                      (lambda* (#:key inputs #:allow-other-keys)