summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-02 23:23:43 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-02 23:23:43 +0100
commit3b509259bf041c507dab23324ba2fedbfc7a6561 (patch)
tree08dd3a896e6534719c5760613889b058be827bc8 /gnu/packages/man.scm
parentd460204f2efa8d6f169707d0245dff8735fc0eba (diff)
downloadguix-3b509259bf041c507dab23324ba2fedbfc7a6561.tar.gz
gnu: man-pages: Build sequentially.
Fixes <http://bugs.gnu.org/18701>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/man.scm (man-pages)[arguments]: Add #:parallel-build? #f.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index c143697883..3d5d02ea64 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -129,6 +129,12 @@ the traditional flat-text whatis databases.")
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-delete 'configure %standard-phases)
+
+       ;; The 'all' target depends on three targets that directly populate
+       ;; $(MANDIR) based on its current contents.  Doing that in parallel
+       ;; leads to undefined behavior (see <http://bugs.gnu.org/18701>.)
+       #:parallel-build? #f
+
        #:tests? #f
        #:make-flags (list (string-append "MANDIR="
                                          (assoc-ref %outputs "out")