summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-09 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-09 02:00:00 +0200
commitbc435c595f7ad988da37c8c5a62f54956bd873cf (patch)
tree73635ae4c2d031f0672768e4d03f506de4eddb0a /gnu/packages/man.scm
parent09bab971aa02ccc5f59c82a81b250d870879f073 (diff)
downloadguix-bc435c595f7ad988da37c8c5a62f54956bd873cf.tar.gz
gnu: man-pages: Update to 6.00.
* gnu/packages/man.scm (man-pages): Update to 6.00.
[arguments]: Add a new 'skip-html phase.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 50796df89e..8ecb62dbe2 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -269,7 +269,7 @@ PostScript, and PDF.  Additional tools include the @command{man} viewer, and
 (define-public man-pages
   (package
     (name "man-pages")
-    (version "5.13")
+    (version "6.00")
     (source
      (origin
        (method url-fetch)
@@ -279,10 +279,20 @@ PostScript, and PDF.  Additional tools include the @command{man} viewer, and
               (string-append "mirror://kernel.org/linux/docs/man-pages/Archive/"
                              "man-pages-" version ".tar.xz")))
        (sha256
-        (base32 "12vb15gs56g8wl5nqlm4llr508brh4m2lfknhq4lizbxzqzawkb1"))))
+        (base32 "1252c1356z5spya3yl0lcmmymglx3bmfwmamiz1y5l13xqpwbnwy"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases (delete 'configure))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-html
+           ;; As of 6.00, this package tries to convert man pages to HTML with
+           ;; man2html.  The only Guix package currently providing that script
+           ;; is man-for-txr, but that version seems unable to handle relative
+           ;; ‘.so’ statements properly.  Disable HTML generation.
+           (lambda _
+             (substitute* "lib/build-html.mk"
+               (("(html:) .*" _ target) (string-append target "\n")))))
+         (delete 'configure))
 
        ;; The 'all' target depends on three targets that directly populate
        ;; $(MANDIR) based on its current contents.  Doing that in parallel