summary refs log tree commit diff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-05 00:36:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-05 00:36:39 +0200
commit49279343acb25ec93cbb33649d7126b3757e228f (patch)
tree3d3f63a4edbfd0091c8d7165fdaba846ca2089b6 /gnu/packages/markup.scm
parentc63bd847816061e76389e93dc094df98800f081b (diff)
downloadguix-49279343acb25ec93cbb33649d7126b3757e228f.tar.gz
gnu: cmark: Fix test failure with Python 3.8.
* gnu/packages/markup.scm (cmark)[source](modules, snippet): New fields.
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index c1fc71b0a2..240bb9e8f4 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -205,7 +206,16 @@ implementation.
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "0r7jpqhgnssq444i8pwji2g36058vfzwkl70wbiwj13h4w5rfc8f"))))
+               "0r7jpqhgnssq444i8pwji2g36058vfzwkl70wbiwj13h4w5rfc8f"))
+             (modules '((guix build utils)))
+             (snippet
+              '(begin
+                 ;; Mimic upstream commit 68c3a91166347 to fix a test failure
+                 ;; when using Python 3.8.  Remove for versions > 0.29.
+                 ;; See <https://github.com/commonmark/cmark/issues/313>.
+                 (substitute* "test/normalize.py"
+                   (("cgi") "html"))
+                 #t))))
     (build-system cmake-build-system)
     (arguments
      '(#:test-target "test"))