summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-08 22:53:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-08 22:53:43 +0200
commite3ec6c806a1ded623280b1520a823e4c9c1bfb16 (patch)
tree3f504109603fbaa5d58d368c91346022d1018838 /gnu/packages/mate.scm
parent27caff1b5d84f200c827d2ca777208b1f3e83393 (diff)
downloadguix-e3ec6c806a1ded623280b1520a823e4c9c1bfb16.tar.gz
gnu: mate-themes: Update to 3.20.9.
* gnu/packages/mate.scm (mate-themes): Update to 3.20.9.
[source]: Update package location.
[inputs]: Remove gtk+-2, add gtk+-3.
[description]: Add note about dual gtk+-2/gtk+-3 support.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 7b309e4437..fc4eb84864 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -61,23 +61,22 @@
 (define-public mate-themes
   (package
     (name "mate-themes")
-    (version "1.12.2")
+    (version (package-version gtk+))
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://pub.mate-desktop.org/releases/"
-                                  (version-major+minor version) "/"
-                                  name "-gtk"
+              (uri (string-append "http://pub.mate-desktop.org/releases/themes/"
                                   (version-major+minor (package-version gtk+))
-                                  "-" version ".tar.xz"))
+                                  "/mate-themes-" (package-version gtk+)
+                                  ".tar.xz"))
               (sha256
                (base32
-                "0kyrlgs5azzj60gnxx2n9qszcligxn959wr42wr0iqnrpiygk5nf"))))
+                "12p6xvqs8smbk9nivi43089fiw1jbb3g9836arr0sksmmziklnvy"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
     (inputs
-     `(("gtk+" ,gtk+-2)
+     `(("gtk+" ,gtk+)
        ("gdk-pixbuf" ,gdk-pixbuf)
        ("gtk-engines" ,gtk-engines)
        ("murrine" ,murrine)))
@@ -86,7 +85,8 @@
      "Official themes for the MATE desktop")
     (description
      "This package includes the standard themes for the MATE desktop, for
-example Menta, TraditionalOk, GreenLaguna or BlackMate.")
+example Menta, TraditionalOk, GreenLaguna or BlackMate.  This package has
+themes for both gtk+-2 and gtk+-3.")
     (license (list license:lgpl2.1+ license:cc-by-sa3.0 license:gpl3+
                    license:gpl2+))))