summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-15 22:22:42 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-15 22:49:49 +0200
commit1038f7d6812dc4b70958dc89dafa65ebdbbe0f68 (patch)
treeada7279fdeeeefe6415a1a3ec380853a15548c16 /gnu/packages/maths.scm
parent20eadd425e7d80dac73e54b33e41643942048aa8 (diff)
downloadguix-1038f7d6812dc4b70958dc89dafa65ebdbbe0f68.tar.gz
gnu: openblas: Remove input labels.
* gnu/packages/maths.scm (openblas)[inputs, native-inputs]: Remove labels.
[arguments]: In 'set-extralib' phase, use 'search-input-file'.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9bcf788c3c..732a7c0020 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4534,14 +4534,14 @@ parts of it.")
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Get libgfortran found when building in utest.
              (setenv "FEXTRALIB"
-                     (string-append "-L" (assoc-ref inputs "fortran-lib")
-                                    "/lib")))))))
+                     (string-append
+                      "-L"
+                      (dirname
+                       (search-input-file inputs "/lib/libgfortran.so")))))))))
     (inputs
-     `(("fortran-lib" ,gfortran "lib")))
+     (list `(,gfortran "lib")))
     (native-inputs
-     `(("cunit" ,cunit)
-       ("fortran" ,gfortran)
-       ("perl" ,perl)))
+     (list cunit gfortran perl))
     (home-page "https://www.openblas.net/")
     (synopsis "Optimized BLAS library based on GotoBLAS")
     (description