summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-07-30 11:18:12 -0300
committerVinicius Monego <monego@posteo.net>2023-09-30 10:37:47 -0300
commit39eb0d8a9454b96dbdbc5d098c95d9da4fb071ae (patch)
tree3ab674015903b1847ab641e9f4af5ffd93abedf8 /gnu/packages/maths.scm
parent5cb1766ad826b322db10d871ae7a1068d926e40e (diff)
downloadguix-39eb0d8a9454b96dbdbc5d098c95d9da4fb071ae.tar.gz
gnu: Add bonmin.
* gnu/packages/maths.scm (bonmin): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bb60877625..9e34da7ad0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1368,6 +1368,28 @@ Extern C linkage permits the package routines to be called from C++.")
     (license (license:non-copyleft ; original minpack license
               "https://github.com/certik/minpack/blob/master/LICENSE"))))
 
+(define-public bonmin
+  (package
+    (name "bonmin")
+    (version "1.8.9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/coin-or/Bonmin")
+                    (commit (string-append "releases/" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "153kj4wx386609g21hw3cv5yxps62qqrc64zwb9ryd2xad1w1a4y"))))
+    (build-system gnu-build-system)
+    (native-inputs (list gfortran pkg-config))
+    (inputs (list cbc ipopt lapack))
+    (home-page "https://coin-or.github.io/Bonmin/")
+    (synopsis "Basic Open-source Nonlinear Mixed INteger programming")
+    (description "Bonmin is a code for solving general MINLP (Mixed Integer
+NonLinear Programming) problems.  It builds on top of Cbc and Ipopt.")
+    (license license:epl1.0)))
+
 (define-public gctp
   (package
     (name "gctp")