summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-08-25 15:12:50 +0200
committerLudovic Courtès <ludo@gnu.org>2020-08-26 00:51:56 +0200
commit3b8eea1c40471e7eab9927966ae17debe7ab54d7 (patch)
tree3f5ffa87809ade789831dd6c9b0c0c2619aa6485 /gnu/packages/maths.scm
parent4c5edee1ef2aff2b8f3782ccb03723a6428bf600 (diff)
downloadguix-3b8eea1c40471e7eab9927966ae17debe7ab54d7.tar.gz
gnu: hdf5: Distinguish the default hdf5 version.
* gnu/packages/maths.scm (hdf5): Rename to...
(hdf-1.8): ... this.
(hdf5-1.10): Adjust accordingly.
(hdf5): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e3209c1e50..64b684100d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1053,7 +1053,7 @@ incompatible with HDF5.")
     (synopsis
      "HDF4 without netCDF API, can be combined with the regular netCDF library")))
 
-(define-public hdf5
+(define-public hdf5-1.8
   (package
     (name "hdf5")
     (version "1.8.21")
@@ -1181,7 +1181,7 @@ extremely large and complex data collections.")
               "https://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
 
 (define-public hdf5-1.10
-  (package (inherit hdf5)
+  (package (inherit hdf5-1.8)
     (version "1.10.6")
     (source
      (origin
@@ -1199,6 +1199,10 @@ extremely large and complex data collections.")
        (base32 "1gf38x51128hn00744358w27xgzjk0ff4wra4yxh2lk804ck1mh9"))
       (patches (search-patches "hdf5-config-date.patch"))))))
 
+(define-public hdf5
+  ;; Default version of HDF5.
+  hdf5-1.8)
+
 (define-public hdf-java
   (package
     (name "hdf-java")