summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-08-21 22:12:28 +0200
committerAndreas Enge <andreas@enge.fr>2023-09-13 11:18:42 +0200
commit6a01c1142b0099bc5ccff6550c2dd24b90ec6aad (patch)
tree19d3953f423ecc2100f96bb0c8951a1f0f16f0da /gnu/packages/maths.scm
parentc30c9df5e9eb2d28e1b593128f05a0aae1919826 (diff)
downloadguix-6a01c1142b0099bc5ccff6550c2dd24b90ec6aad.tar.gz
gnu: hdf4, hdf4-alt: Update to 4.2.16-2.
* gnu/packages/maths.scm (hdf4)[source]: Update to 4.2.16-2. Drop patches
that do not apply any more.
[arguments]: Drop configure flag related to libtirpc. Add configure flag
to build xdr library and drop unneeded substitutions.
* gnu/packages/patches/hdf4-architectures.patch,
gnu/packages/patches/hdf4-tirpc.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Unregister patches.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm28
1 files changed, 8 insertions, 20 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 38e71e18f8..e3cd0762be 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2020 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2020, 2023 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2016, 2017 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2014-2022 Eric Bavier <bavier@posteo.net>
@@ -1321,18 +1321,16 @@ computations.")
 (define-public hdf4
   (package
     (name "hdf4")
-    (version "4.2.14")
+    (version "4.2.16-2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://support.hdfgroup.org/ftp/HDF/releases/HDF"
                            version "/src/hdf-" version ".tar.bz2"))
        (sha256
-        (base32 "0n29klrrbwan9307np0d9hr128dlpc4nnlf57a140080ll3jmp8l"))
-       (patches (search-patches "hdf4-architectures.patch"
-                                "hdf4-reproducibility.patch"
-                                "hdf4-shared-fortran.patch"
-                                "hdf4-tirpc.patch"))))
+        (base32 "0b395czhqr43mmbiifmg2mhb488wnd4zccj45vpql98ja15j7hy5"))
+       (patches (search-patches "hdf4-reproducibility.patch"
+                                "hdf4-shared-fortran.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      (list gfortran bison flex))
@@ -1345,9 +1343,7 @@ computations.")
        #:configure-flags (list "--enable-shared"
                                "FCFLAGS=-fallow-argument-mismatch"
                                "FFLAGS=-fallow-argument-mismatch"
-                               (string-append "CPPFLAGS=-I"
-                                              (assoc-ref %build-inputs "libtirpc")
-                                              "/include/tirpc"))
+                               "--enable-hdf4-xdr")
        #:phases
        (modify-phases %standard-phases
          ;; This is inspired by two of Debian's patches.
@@ -1362,14 +1358,7 @@ computations.")
              (substitute*
                  '("mfhdf/hdfimport/testutil.sh.in" "hdf/util/testutil.sh.in")
                (("/bin/rm") "rm")
-               (("/bin/mkdir") "mkdir"))
-             (substitute* (find-files "." "^Makefile\\.in$")
-               (("@HDF_BUILD_XDR_TRUE@XDR_ADD = \
--R\\$\\(abs_top_builddir\\)/mfhdf/xdr/\\.libs") "")
-               (("@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = \
--R\\$\\(abs_top_builddir\\)/mfhdf/libsrc/\\.libs \
--R\\$\\(abs_top_builddir\\)/hdf/src/\\.libs \\$\\(XDR_ADD\\)") ""))
-             #t))
+               (("/bin/mkdir") "mkdir"))))
          (add-after 'configure 'patch-settings
            (lambda _
              ;; libhdf4.settings contains the full path of the
@@ -1389,8 +1378,7 @@ computations.")
                ;; files.  Fix it manually to avoid having to propagate it.
                (substitute* (find-files (string-append out "/lib") "\\.la$")
                  (("-ljpeg")
-                  (string-append "-L" libjpeg "/lib -ljpeg")))
-               #t))))))
+                  (string-append "-L" libjpeg "/lib -ljpeg")))))))))
     (home-page "https://www.hdfgroup.org/products/hdf4/")
     (synopsis
      "Library and multi-object file format for storing and managing data")