summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-27 09:39:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-03-28 09:34:33 +0300
commit6f766069843419ce862be79e15523c43036f7bc6 (patch)
tree9c3cb364a9d6774e285bb48bfe635dbf5fdf383e /gnu/packages/maths.scm
parentc17383f400d3b942c22ec46b556cad8ca3a2fce1 (diff)
downloadguix-6f766069843419ce862be79e15523c43036f7bc6.tar.gz
gnu: gsl: Disable tests on aarch64-linux.
* gnu/packages/maths.scm (gsl)[arguments]: Do not run the test suite on
aarch64-linux.
[home-page]: Use https.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8fad8f0aef..f2e0c663e4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -270,8 +270,14 @@ semiconductors.")
               (patches (search-patches "gsl-test-i686.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:parallel-tests? #f))
-    (home-page "http://www.gnu.org/software/gsl/")
+     `(#:parallel-tests? #f
+       ;; Currently there are numerous tests that fail on "exotic"
+       ;; architectures such as aarch64 and ppc64le.
+       ,@(if (string-prefix? "aarch64-linux"
+                             (or (%current-target-system) (%current-system)))
+           '(#:tests? #f)
+           '())))
+    (home-page "https://www.gnu.org/software/gsl/")
     (synopsis "Numerical library for C and C++")
     (description
      "The GNU Scientific Library is a library for numerical analysis in C