summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:50 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:45 +0200
commita764c7c0b91f20a0e3cb11fcf778965d3b1f6c2c (patch)
tree6c316d770b70e7e4d0de63b826a9d920cc275bb6 /gnu/packages/maths.scm
parent3fc3b35738c4c854bb34c9e929a254bbe8d28b25 (diff)
downloadguix-a764c7c0b91f20a0e3cb11fcf778965d3b1f6c2c.tar.gz
gnu: Add suitesparse-ccolamd.
* gnu/packages/maths.scm (suitesparse-ccolamd): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fade383ca7..30d6351a0a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5279,6 +5279,40 @@ ordering.")
 matrix with which the LU factorization becomes sparser.")
     (license license:bsd-3)))
 
+(define-public suitesparse-ccolamd
+  (package
+    (name "suitesparse-ccolamd")
+    (version "3.2.0")
+    (source suitesparse-source)
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir
+            (lambda _
+              (chdir "CCOLAMD")))
+          (add-after 'chdir 'set-cmake-module-path
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("set.*CMAKE_MODULE_PATH.*")
+                 (string-append "set(CMAKE_MODULE_PATH "
+                                #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+                                "set(DUMMY\n")))))
+          (replace 'install-license-files
+            (lambda _
+              (install-file "../CCOLAMD/Doc/License.txt"
+                            (string-append #$output "/share/doc/"
+                                           #$name "-" #$version)))))))
+    (inputs (list suitesparse-config))
+    (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+    (synopsis "Column Approximate Minimum Degree Ordering with constraints")
+    (description "CCOLAMD is library for computing a permutation vector for a
+matrix with which the LU factorization becomes sparser.  It is a variant of
+COLAMD which has the the option to apply constraints to the ordering.")
+    (license license:bsd-3)))
+
 (define-public suitesparse
   (package
     (name "suitesparse")