summary refs log tree commit diff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 14:28:59 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:11:05 +0200
commit506165869207f2356fb46df5889b33f8e873a7f9 (patch)
tree3413cd39ba6bbe1b6d484e3d324d87c3c7a95214 /gnu/packages/maven-parent-pom.scm
parenta2f64c345e827d419bf21831bfef474bf41ea4a9 (diff)
downloadguix-506165869207f2356fb46df5889b33f8e873a7f9.tar.gz
gnu: Add apache-commons-parent-pom-39.
* gnu/packages/maven-parent-pom.scm (apache-commons-parent-pom-39): New
variable.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index 073ac36944..d40209d221 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -81,3 +81,38 @@
 (define-public apache-parent-pom-21
   (make-apache-parent-pom
     "21" "0clcbrq1b2b8sbvlqddyw2dg5niq25dhdma9sk4b0i30hqaipx96"))
+
+(define (make-apache-commons-parent-pom version hash parent)
+  (hidden-package
+    (package
+      (name "apache-commons-parent-pom")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/apache/commons-parent")
+                       (commit (string-append "commons-parent-" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32 hash))))
+      (build-system ant-build-system)
+      (arguments
+       `(#:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'build)
+           (replace 'install
+             (install-pom-file "pom.xml")))))
+      (propagated-inputs
+        (if parent
+            `(("parent" ,parent))
+            '()))
+      (home-page "https://maven.apache.org/")
+      (synopsis "Apache Commons parent pom")
+      (description "This package contains the Apache Commons parent POM.")
+      (license license:asl2.0))))
+
+(define-public apache-commons-parent-pom-39
+  (make-apache-commons-parent-pom
+    "39" "0mjx48a55ik1h4hsxhifkli1flvkp6d05ab14p4al0fc6rhdxi46"
+    apache-parent-pom-16))