summary refs log tree commit diff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-03 20:52:43 +0100
committerMarius Bakke <marius@gnu.org>2022-11-11 18:09:58 +0100
commit94913eabbb9f1f3772867bf14e9f9d5e15bc2a6d (patch)
treea8376dbd249e722535b5ee44993746474928db5c /gnu/packages/maven.scm
parentbdfa795c980b8562ed45672187babc7be3bde150 (diff)
downloadguix-94913eabbb9f1f3772867bf14e9f9d5e15bc2a6d.tar.gz
gnu: maven-model: Avoid usage of (guix build syscalls).
* gnu/packages/maven.scm (maven-3.0-model)[arguments]: Use MKDTEMP instead of
MKDTEMP!.
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index d3e5677669..b73fef79ba 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -2319,7 +2319,6 @@ reporting or the build process.")))
        #:modules
        ((guix build ant-build-system)
         (guix build java-utils)
-        (guix build syscalls)
         (guix build utils))
        #:phases
        (modify-phases %standard-phases
@@ -2328,7 +2327,7 @@ reporting or the build process.")))
              ;; The model has almost not changed, but the newer version is
              ;; needed to prevent an error in the newer modello we have
              (let ((source (assoc-ref inputs "maven-source"))
-                   (dir (mkdtemp! "maven-source-XXXXXXXX")))
+                   (dir (mkdtemp "maven-source-XXXXXXXX")))
                (with-directory-excursion dir
                  (invoke "tar" "xf" source)
                  (copy-file (car (find-files "." "maven.mdo"))