summary refs log tree commit diff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-21 01:49:43 -0400
committerMark H Weaver <mhw@netris.org>2015-07-21 02:05:20 -0400
commitc0eac5a86246a2c8eb4fe3177a64cfc9687cf5e0 (patch)
treeef31bdae1d9aa09f3b99887c3523aee644aeaf25 /gnu/packages/mp3.scm
parent4d85391059604959a010c39953bea5c62f52dc90 (diff)
downloadguix-c0eac5a86246a2c8eb4fe3177a64cfc9687cf5e0.tar.gz
gnu: libmad: Apply fixes for ARMv7 Thumb, etc.
* gnu/packages/patches/libmad-armv7-thumb-pt1.patch,
  gnu/packages/patches/libmad-armv7-thumb-pt2.patch,
  gnu/packages/patches/libmad-frame-length.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/mp3.scm (libmad)[source]: Add patches.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 163e075f18..77eae65584 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -52,7 +53,10 @@
             (sha256
              (base32
               "14460zhacxhswnzb36qfpd1f2wbk10qvksvm6wyq5hpvdgnw7ymv"))
-            (patches (list (search-patch "libmad-mips-newgcc.patch")))))
+            (patches (map search-patch '("libmad-armv7-thumb-pt1.patch"
+                                         "libmad-armv7-thumb-pt2.patch"
+                                         "libmad-frame-length.patch"
+                                         "libmad-mips-newgcc.patch")))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases