summary refs log tree commit diff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-02 23:13:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 23:13:06 +0200
commit9880bba2c8ebb30c35e34b5ff4314ece8f759528 (patch)
treeee364017c6516d9a3b3c917c6a21e13bf5ff54fe /gnu/packages/mpd.scm
parent29a4fe8b59003ee28df0e902525ef5de1b505fea (diff)
downloadguix-9880bba2c8ebb30c35e34b5ff4314ece8f759528.tar.gz
gnu: ncmpc: Remove GCC8 input.
* gnu/packages/mpd.scm (ncmpc)[native-inputs]: Remove GCC-8.
[arguments]: Remve <#:phases>.
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 654d1e4edc..f72256fe50 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -33,7 +33,6 @@
   #:use-module (guix build-system python)
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages boost)
-  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
@@ -198,19 +197,8 @@ player daemon.")
        ;; Otherwise, they are installed incorrectly, in
        ;; '$out/share/man/man/man1'.
        (list (string-append "-Dmandir=" (assoc-ref %outputs "out")
-                            "/share"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'expand-C++-include-path
-           ;; Make <gcc>/include/c++/ext/string_conversions.h find <stdlib.h>.
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((path "CPLUS_INCLUDE_PATH")
-                    (gcc  (assoc-ref inputs "gcc"))
-                    (c++  (string-append gcc "/include/c++")))
-               (setenv path (string-append c++ ":" (getenv path)))
-               #t))))))
-    (inputs `(("gcc" ,gcc-8)            ; for its C++14 support
-              ("boost" ,boost)
+                            "/share"))))
+    (inputs `(("boost" ,boost)
               ("pcre" ,pcre)
               ("libmpdclient" ,libmpdclient)
               ("ncurses" ,ncurses)))