summary refs log tree commit diff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-19 17:51:39 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-20 11:58:40 -0600
commitac356fd6abf31c7cd102b27abacc9fc6047142e7 (patch)
tree98f3eaf3a60a620c942e30390c5504344925873e /gnu/packages/mpi.scm
parent2f5b6a1f1815a4e2118dabdb65aa8471b11badec (diff)
downloadguix-ac356fd6abf31c7cd102b27abacc9fc6047142e7.tar.gz
gnu: openmpi: Update to 1.10.1.
* gnu/packages/mpi.scm (openmpi): Update to 1.10.1.
  [arguments]: Remove now-unsupported configure flags.  Add
  --enable-builtin-atomics.  Remove development-oriented
  --enable-debug.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 87aa763747..420291d7f0 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -93,7 +93,7 @@ bind processes, and much more.")
 (define-public openmpi
   (package
     (name "openmpi")
-    (version "1.8.5")
+    (version "1.10.1")
     (source
      (origin
       (method url-fetch)
@@ -102,7 +102,7 @@ bind processes, and much more.")
                           "/downloads/openmpi-" version ".tar.bz2"))
       (sha256
        (base32
-        "1i7vjf599kl5lm8n4vnwq9q1d9scn4sdjh42kfq1i9yzxnlhdsjc"))))
+        "14p4px9a3qzjc22lnl6braxrcrmd9rgmy7fh4qpanawn2pgfq6br"))))
     (build-system gnu-build-system)
     (inputs
      `(("hwloc" ,hwloc)
@@ -113,16 +113,12 @@ bind processes, and much more.")
        ("perl" ,perl)))
     (arguments
      `(#:configure-flags `("--enable-static"
-                           "--enable-oshmem"
 
-                           "--enable-event-thread-support"
-                           "--enable-opal-multi-threads"
-                           "--enable-orte-progress-threads"
                            "--enable-mpi-thread-multiple"
+                           "--enable-builtin-atomics"
 
                            "--enable-mpi-ext=all"
                            "--with-devel-headers"
-                           "--enable-debug"
                            "--enable-memchecker"
                            ,(string-append "--with-valgrind="
                                            (assoc-ref %build-inputs "valgrind"))