summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 11:55:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:05 -0400
commit00dff2c76853980a70079fe682d184bb6ef16b03 (patch)
tree50b627f2c9f10704dd404991cd2caaf83db4c86a /gnu/packages/music.scm
parentceee9eb31276b5758155377e1f59a78c7030c543 (diff)
downloadguix-00dff2c76853980a70079fe682d184bb6ef16b03.tar.gz
gnu: Remove beast.
* gnu/packages/music.scm (beast): Delete variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 756e1ca45b..b3989e11f9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2507,48 +2507,6 @@ modification devices that brought world-wide fame to the names and products of
 Laurens Hammond and Don Leslie.")
     (license license:gpl2+)))
 
-(define-public beast
-  (package
-    (name "beast")
-    (version "0.10.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://testbit.eu/pub/dists/beast/beast-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1jzzmfwssklzw8fvvil04n8csc0zm99fnd9p2xa7c0xchg37lvhn"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:parallel-build? #f)) ; Race conditions cause build failures
-    (inputs
-     `(("rapicorn" ,rapicorn)
-       ("guile" ,guile-1.8)
-       ("python" ,python-2)
-       ("libgnomecanvas" ,libgnomecanvas)
-       ("libogg" ,libogg)
-       ("libmad" ,libmad)
-       ("flac" ,flac)
-       ("alsa-lib" ,alsa-lib)
-       ("libvorbis" ,libvorbis)
-       ("gettext" ,gettext-minimal)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib:bin" ,glib "bin")
-       ("cython" ,python2-cython)
-       ("perl" ,perl)
-       ("perl-xml-parser" ,perl-xml-parser)))
-    (home-page "https://testbit.eu/wiki/Beast_Home")
-    (synopsis "Music composition and modular synthesis environment")
-    (description
-     "Beast is a music composition and modular synthesis application.  It
-supports a wide range of standards in the field, such as MIDI, various audio
-file formats and LADSPA modules.  It allows for multitrack editing, real-time
-synthesis, 32bit audio rendering, precise timing down to sample granularity,
-on-demand and partial loading of wave files, on the fly decoding, stereo
-mixing, FFT scopes, MIDI automation and full scriptability in Scheme.")
-    (license license:gpl3+)))
-
 (define-public bristol
   (package
     (name "bristol")