summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorterramorpha@cock.li <terramorpha@cock.li>2021-07-10 15:42:25 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-07-14 09:23:24 +0300
commit14bf5890c37cf0cf1027341cb6d6cb17d0061f91 (patch)
tree29356eeebc503bd2b1f59ef9fde2d1995f2f78b8 /gnu/packages/music.scm
parent2847022dc761bb0e8f83b1e0c7739f79a5e14a56 (diff)
downloadguix-14bf5890c37cf0cf1027341cb6d6cb17d0061f91.tar.gz
gnu: Add a2jmidid.
* gnu/packages/music.scm (a2jmidid): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 28661c5667..f814340289 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -39,6 +39,7 @@
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
 ;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6679,3 +6680,45 @@ It is provided as an LV2 plugin and as a standalone Jack application.")
   framework.")
       (home-page "http://shiru.untergrund.net/software.shtml")
       (license license:wtfpl2))))
+
+(define-public a2jmidid
+  (package
+    (name "a2jmidid")
+    (version "9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jackaudio/a2jmidid")
+                    (commit version)))
+              (sha256
+               (base32 "1x6rcl3f4nklnx4p5jln9a7fpj9y7agjxs9rw7cccmwnski7pnsq"))
+              (file-name (git-file-name name version))))
+    (arguments
+     `(#:tests? #f      ; No tests.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-programs
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin/")))
+               (substitute* (string-append bin "a2j")
+                 (("a2j_control") (string-append bin "a2j_control")))
+               (wrap-program (string-append bin "a2j_control")
+                `("PYTHONPATH" prefix (,(getenv "PYTHONPATH"))))
+               #t))))))
+    (build-system meson-build-system)
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("bash-minimal" ,bash-minimal)   ; for wrap-program
+       ("dbus" ,dbus)
+       ("jack" ,jack-1)
+       ("python" ,python)
+       ("python-dbus" ,python-dbus)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "ALSA sequencer to JACK MIDI bridging")
+    (description
+     "@code{a2jmidid} is a daemon that implements automatic bridging of ALSA
+midi devices to JACK midi devices.")
+    (home-page "https://github.com/jackaudio/a2jmidid")
+    (license license:gpl2)))