summary refs log tree commit diff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-09-06 10:55:21 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-09-06 11:01:52 -0400
commit21f5f351fb4a21a8051cdb2b747fef57aa2fa8d4 (patch)
treed084e04a680ee1bd5578214c6d4210640f371c21 /gnu/packages/music.scm
parentfd3a64335da5a591dbe9276395d0ad6bb09f00bb (diff)
downloadguix-21f5f351fb4a21a8051cdb2b747fef57aa2fa8d4.tar.gz
gnu: libgme: Update to 0.6.2.
* gnu/packages/music.scm (libgme): Update to 0.6.2.
[native-inputs]: Add gcc-4.9.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ba21e5da2b..e39478e794 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -786,18 +786,23 @@ interface.  It is implemented as a frontend to @code{klick}.")
 (define-public libgme
   (package
     (name "libgme")
-    (version "0.6.1")
+    (version "0.6.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
                                   "downloads/game-music-emu-" version
-                                  ".tar.bz2"))
+                                  ".tar.xz"))
               (sha256
                (base32
-                "08fk7zddpn7v93d0fa7fcypx7hvgwx9b5psj9l6m8b87k2hbw4fw"))))
+                "0hkkmxbaas2sirlb5i4r10mgbbiaapjx8pazifabwba23m3wnijh"))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f)) ; no check target
+    (native-inputs
+     `(;; Use gcc-4.9 to work around an internal compiler error that happens
+       ;; when using gcc-5.5.0.  FIXME: Try removing this when the default
+       ;; compiler is no longer gcc-5.5.0.
+       ("gcc" ,gcc-4.9)))
     (home-page "https://bitbucket.org/mpyne/game-music-emu")
     (synopsis "Video game music file playback library")
     (description